Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Could not use keyboard and mouse at KDM log in screen in FreeBSD 9.0 KDE Typed on nano:

hald_enable="YES"
dbus_enable="YES"
local_startup=${local_startup} /usr/local/kde4/etc/rc.d"
kdm4_enable="YES"

after saving I reboot and log in screen appears but mouse and keyboard not enabled.

share|improve this question
    
Have you installed the mouse and keyboard drivers for xorg? –  D_Bye Mar 22 '13 at 10:02
    
Is it USB or PS2? If USB you might want to try a PS2 keyboard and mouse. It won't solve the problem, but will help you moving around quicker to solve the USB problem. –  rxt Mar 22 '13 at 15:23
    
Have you tried to add AllowEmptyInput to your xorg.conf? –  arved Mar 29 '13 at 10:19
add comment

1 Answer

I was stuck with the same issue some minutes ago. After many unsuccessful queries using search engines, I checked the log to try to understand why those input methods weren't working.

In my case, installing the following 2 ports solved. I hope that it can help you out.

cd /usr/ports/x11-drivers/xf86-input-keyboard && sudo make install clean
cd /usr/ports/x11-drivers/xf86-input-mouse && sudo make install clean

After installing those, I rebooted my FreeBSD box and was able to get through the gdm login window.

[ PS: same answer as given in http://unix.stackexchange.com/a/72402/37151, since it is a similar issue from my point of view. ]

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.