Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to configure a Cisco (small business 300) via serial port. I read here: http://www.commandlinefu.com/commands/view/6130/use-screen-as-a-terminal-emulator-to-connect-to-serial-consoles

That I can use screen to connect to the switch, but when I try the command

screen /dev/ttyUSB0 9600

All I get is a bunch of weird characters.

The gear is connected via a Logilink serial-usb adapter. I had found the name of the chip in that, but now I cant seem to find it again.

This is on debian 7.0, but I have tried it on a linux mint as well. Didn't work either.

Edit: Tried minicom first, didn't work. Which was why I turned to google and found the above site. It seems to work well with screen though, meaning I have just tried it on a windows 7+putty with the newest drivers and it produces the exact same output as with screen. So I am starting to think the damn dongle might be broken.

share|improve this question
    
Not an answer, but I personally use putty for this. Configuration is a bit easier. –  jordanm Mar 21 '13 at 18:36
2  
Putty is usually Windows-centric. I personally use minicom to connect to an ASA. Works just fine. –  schaiba Mar 21 '13 at 19:01
    
added some clarification. –  Mathias Nielsen Mar 21 '13 at 20:58
    
screen works fine for serial connections, but you have to supply it with the correct speed and negotiation options. Weird characters can occur when you have the wrong ones - or a bad cable. –  frostschutz Mar 23 '13 at 14:47
add comment

1 Answer 1

up vote 2 down vote accepted

As it turns out. The fault was neither the dongle, nor was it screen.

The Small Business 300 series uses 115200 baud unlike the rest of cisco's equipment that uses 9600 baud.

Using the command:

screen /dev/ttyUSB1 115200

Did the trick. Thanks for playing guys :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.