Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Though Mint 14 is based on Ubuntu 12.10 I get the following error when running the Intel Driver Manager under Mint:

diagnostics-view.c/diagnostics_view_start: Running diagnostic Checking distribution...
main-window.c/on_diagnostics_finished: Diagnostics finished with an error

Yes, I am using the correct 64 bit edition for my install

By the way, I am using a VIZIO CT15-A5 15.6-Inch Thin + Light Ultrabook with the Intel HD 4000 graphics processor and at present my System information says the following for display:

Display
Display
Resolution  1920x1080 pixels
Vendor  The X.Org Foundation
Version 1.13.0
Monitors
Monitor 0   1920x1080 pixels
Extensions
BIG-REQUESTS    
Composite   
DAMAGE  
DOUBLE-BUFFER   
DPMS    
DRI2    
GLX 
Generic Event Extension 
MIT-SCREEN-SAVER    
MIT-SHM 
RANDR   
RECORD  
RENDER  
SECURITY    
SGI-GLX 
SHAPE   
SYNC    
X-Resource  
XC-MISC 
XFIXES  
XFree86-DGA 
XFree86-VidModeExtension    
XINERAMA    
XInputExtension 
XKEYBOARD   
XTEST   
XVideo  
XVideo-MotionCompensation   

OpenGL

Vendor  Intel Open Source Technology Center
Renderer    Mesa DRI Intel(R) Ivybridge Mobile
Version 3.0 Mesa 9.0.3
Direct Rendering    Yes

Here is the output of inxi -Gx

funkdified@vizio ~ $ inxi -Gx
Graphics:  Card: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0 
           X.Org: 1.13.0 drivers: intel (unloaded: fbdev,vesa) Resolution: 1920x1080@60.0hz 
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 9.0.3 Direct Rendering: Yes
share|improve this question
1  
According to Intel page only two distros are supported: Fedora and Ubuntu. It looks like it doesn't find some Ubuntu specific stuff on your Mint install. Have you tried running it through gdb or strace ? Also (just curious), why do you need this particular app from Intel ? Intel graphics driver should be available from your distro repository. –  don_crissti Apr 14 '13 at 14:27
    
Hi can you please elaborate on that last point? Where would I find it, and how? –  Abram Apr 14 '13 at 20:07
    
Well, I'm on Arch, so I forgot most popular distros include the package by default. In Mint I think it's called xserver-xorg-video-intel and your system should already use the intel driver. The OpenGL part from glxinfo in your post seems to confirm that. You can double check (in terminal) with inxi -Gx (output should contain driver: intel). –  don_crissti Apr 14 '13 at 22:50
    
Hi Don. See my edit. It seems I do have the driver installed. Surprises me though because of the great video playback in windows and poor playback in Mint. Hmmm. I wonder what else I could be doing differently. –  Abram Apr 15 '13 at 6:02
    
I'm on SandyBridge (previous generation) and video playback is on par with Windows. Since you have an Ivy Bridge (better hardware) you shouldn't experience any issues. I do however use SNA acceleration as the driver defaults to the more mature but slower UXA. (see UXA vs SNA benchmarks on Ivy Bridge). Here is an example of how to enable SNA via xorg configuration file. Give it a try and see if video playback improves. –  don_crissti Apr 15 '13 at 11:54

2 Answers 2

up vote 0 down vote accepted
+100

The reason you are getting that error is probably because the Intel Driver Manager is not checking whether it can install on your distribution, it is just checking whether the distribution is Fedora or Ubuntu. This is usually done with the command

`uname -v`

For example:

$ uname -v
#36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012

or $ uname -v #1 SMP Debian 3.2.32-1

If the Intel Driver Manager searches for a specific string, for example

$ uname -v | grep 'Fedora\|Ubuntu'

this will return false on a machine running Mint even though Mint is based on Ubuntu.


These are the steps necessary to modify lsb-release as suggested by @don_crissti below (taken from here):

$ sudo cp /etc/lsb-release /etc/lsb-release.bak 
$ sudo pico /etc/lsb-release

Replace with (I'm not sure exactly which lines are being checked here by intel-linux-graphics-installer, but definitely not the last one.)

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.10
DISTRIB_CODENAME=quantal
DISTRIB_DESCRIPTION="Linux Mint 14 Nadia"

$ sudo intel-linux-graphics-installer

Follow installer and wait for it to ask you to reboot. Once it is finished:

$ sudo rm /etc/lsb-release $ sudo mv /etc/lsb-release.bak /etc/lsb-release

share|improve this answer
    
There is a workaround that I am after. I read about it once.. you can modify a file in the driver manager to allow the disto.. but I can't recall how. –  Abram Apr 15 '13 at 20:14
    
@Abram - If you're sure your problems are caused by driver version and not by driver configuration... the checking is done via lsb-release in the source code so you'd have to modify it and re-compile the app. Instead of doing that you could modify lsb-release to trick the app. The workaround is described here. Make sure you read and understand the warnings. –  don_crissti Apr 16 '13 at 13:57
    
Don, I will try your answer and Terdon's when I get hme tonight. I will first try the reconfigure, and then Terdon if I'm still experiencing issues. Thank you so much for your help Don. –  Abram Apr 16 '13 at 19:41

Here is a solution I posted on AskUbuntu

There is a graphics gui by intel for download.

sudo apt-get install intel-linux-graphics-installer

Then run the installer.

Your touchpad mouse may become unresponsive. You can then do

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get upgrade

This fixed the xserver crashes and the mouse wasn't disabled after every reboot. If your mouse is disabled, do

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

But after re-downloading from the ppa, the issue resolved with the touchpad.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.