Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I bought a Linksys AE3000 wireless adapter hoping I could use it on my Ubuntu 12.04 box. I found a website that walked through using it, but it didn't work. I edited rtusb_dev_id.c to add:

and then did sudo make -j10 and got:

make -C tools
make[1]: Entering directory `/home/eduardop911/Desktop/Linux/DPO_RT3573_LinuxSTA_V2.5.0.0/tools'
gcc -g bin2h.c -o bin2h
cp -f os/linux/Makefile.6 /home/eduardop911/Desktop/Linux/DPO_RT3573_LinuxSTA_V2.5.0.0/os/linux/Makefile
make -C /lib/modules/3.2.0-39-generic/build SUBDIRS=/home/eduardop911/Desktop/Linux/DPO_RT3573_LinuxSTA_V2.5.0.0/os/linux modules
make[1]: Leaving directory `/home/eduardop911/Desktop/Linux/DPO_RT3573_LinuxSTA_V2.5.0.0/tools'
/home/eduardop911/Desktop/Linux/DPO_RT3573_LinuxSTA_V2.5.0.0/tools/bin2h
make[1]: Entering directory `/usr/src/linux-headers-3.2.0-39-generic'
CC [M] /home/eduardop911/Desktop/Linux/DPO_RT3573_LinuxSTA_V2.5.0.0/os/linux/../../common/rtmp_mcu.o
LD [M] /home/eduardop911/Desktop/Linux/DPO_RT3573_LinuxSTA_V2.5.0.0/os/linux/rt3573sta.o
Building modules, stage 2.
MODPOST 1 modules
LD [M] /home/eduardop911/Desktop/Linux/DPO_RT3573_LinuxSTA_V2.5.0.0/os/linux/rt3573sta.ko
make[1]: Leaving directory `/usr/src/linux-headers-3.2.0-39-generic'
cp -f /home/eduardop911/Desktop/Linux/DPO_RT3573_LinuxSTA_V2.5.0.0/os/linux/rt3573sta.ko

/tftpboot

then i did the sudo make install:

> make -C
> /home/eduardop911/Desktop/Linux/DPO_RT3573_LinuxSTA_V2.5.0.0/os/linux
> -f Makefile.6 install mkdir: cannot create directory `/etc/Wireless': File exists make[1]: Entering directory
> `/home/eduardop911/Desktop/Linux/DPO_RT3573_LinuxSTA_V2.5.0.0/os/linux'
> rm -rf /etc/Wireless/RT2870STA mkdir /etc/Wireless/RT2870STA cp
> /home/eduardop911/Desktop/Linux/DPO_RT3573_LinuxSTA_V2.5.0.0/RT2870STA.dat
> /etc/Wireless/RT2870STA/. install -d
> /lib/modules/3.2.0-39-generic/kernel/drivers/net/wireless/ install -m
> 644 -c rt3573sta.ko
> /lib/modules/3.2.0-39-generic/kernel/drivers/net/wireless/
> /sbin/depmod -a 3.2.0-39-generic make[1]: Leaving directory
> `/home/eduardop911/Desktop/Linux/DPO_RT3573_LinuxSTA_V2.5.0.0/os/linux'

I finished with:

sudo depmod -a 
sudo modprobe -v rt3573sta

but was not able to get the light to light up. Any suggestions?

share|improve this question
    
Your link says: "Sorry, the page you were looking for in this blog does not exist." In general if you really are buying hardware for use with linux, it's a good idea to check around first for stuff that is known to work out of the box with in tree kernel drivers (which there are plenty of comparable devices in this case that do). Once you get into compiling out of tree stuff from here there and everywhere you are just begging for hassles. That said, have you tried to use the device, eg. via ifconfig or iw tools? –  TAFKA 'goldilocks' Mar 20 '13 at 6:31
add comment

1 Answer

After doing all steps above and rebooting, the drivers started working.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.