Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

How do I change the default gnome-terminal location on screen. I checked out the preferences but they only have option to change default size. I also checked out .gconf/apps/gnome-terminal/ but didnt find any thing out.
All in all my gnome-terminal should normally be gnome-terminal --geometry=80x24+200+200
I dont want to do it through launcher because I will always have to start the terminal from launcher to get that location.

share|improve this question
    
What window-manager are you using? (wmcrtl -m) –  Stéphane Chazelas Mar 15 '13 at 9:41
    
no such command –  Kaunteya Suryawanshi Mar 15 '13 at 12:06
    
Then install it or get your WM name by other means! –  Stéphane Chazelas Mar 15 '13 at 12:23
    
@KaunteyaSuryawanshi: Do you want the terminal to open at that specific location only when invoked via sublime terminal plugin ? –  don_crissti Mar 15 '13 at 12:38
    
@don-crissti yes.. will do.. –  Kaunteya Suryawanshi Mar 15 '13 at 13:19

2 Answers 2

up vote 1 down vote accepted

If it's only the sublime plugin that's bothering you, you just have to edit the plugin preferences and add the geometry parameters:

Preferences > Package settings > Terminal > Settings - Default

{   "terminal": "",
    "parameters": ["--geometry", "80x24+200+200"]   
}

Another way, if you also want Alt-F2 to open a terminal at that location: gnome-shell Alt+F2 runs commands in your $PATH so you could create a new executable (e.g.gterm) somewhere in your $PATH (e.g. /usr/local/bin). Edit /usr/local/bin/gterm like this:

#!/bin/sh

exec gnome-terminal --geometry 80x24+200+200

make it executable:

chmod +x /usr/local/bin/gterm

Now you can run gterm via Alt+F2, it will open a terminal @80x24+200+200. You can also point sublime to gterm (note there's no need for parameters anymore since gterm is already a custom size/position terminal):

Preferences > Package settings > Terminal > Settings - Default

{   "terminal": "gterm",
    "parameters": []    
}
share|improve this answer
    
@don-crissti Great answer man.. Thank you.. –  Kaunteya Suryawanshi Mar 16 '13 at 14:27

Perhaps change your gnome-terminal.desktop file (not sure about the file name),

And set the Exec= line to gnome-terminal --working-directory=/path/to/folder --geometry=80x24+200+200 instead, that way when you open a new instance, it would be in the desired folder already.

share|improve this answer
    
plz check the edited question –  Kaunteya Suryawanshi Mar 15 '13 at 8:43
    
@KaunteyaSuryawanshi updated, you can merge the two command line arguments –  warl0ck Mar 15 '13 at 8:49
    
Not working. And I dont need --working-directory –  Kaunteya Suryawanshi Mar 15 '13 at 9:36
    
I guess the problem with editing .desktop file is that it will only work when we launch the terminal by clicking on the terminal icon.. –  Kaunteya Suryawanshi Mar 15 '13 at 9:38
    
@KaunteyaSuryawanshi What other method do you use? –  warl0ck Mar 15 '13 at 9:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.