Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I pressed Fn+F5 on my Samsung 9 laptop, which disables the touchpad. It worked, but now I can't re-enable it. Clicking (and even click-through tapping) work, but the pointer doesn't move. If I cat /dev/input/mice, it shows output when I use the touchpad. Restarting the laptop doesn't help, and the touchpad is listed as enabled in the various graphical utilities I tried, including xinput. What else can I try? I'm using Ubuntu 12.10 if it matters.

share|improve this question
    
Try disabling gnome-settings-daemon mouse plugin, see if that changes anything: open dconf-editor, go to org > gnome > settings-daemon > plugins > mouse and uncheck active. –  don_crissti Mar 15 '13 at 0:48
add comment

1 Answer

I tried swapping my external mouse (/dev/input/mouse0) and my touchpad (/dev/input/mouse1) by renaming their /dev entries, and then rebooting fixed it somehow. I was thinking that renaming devices forced linux to "rescan" (recreate) the /dev files, but then I thought that the /dev filesystem is mounted every reboot and recreated by the kernel, so I don't really understand why that worked.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.