Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I can't boot my Debian system, I got this error during boot up:

Driver 'pcspkr' is already registered, aborting.

I have solved this by adding blacklist snd-pscp to /etc/modprobe.d/blacklist.conf (inspired by this

Now I can't see this error during boot up, but my computer prints this and stops (shell not running, I can type text and it displays on screen, but I can't run any command (nothing happens on enter))

[10.175214] [drm] nouveau 0000:01:00.0: Setting dpms mode 0 on vga encoder (output 0)
[10.175223] [drm] nouveau 0000:01:00.0: Output VGA-1 is running on CRTC 0 using output 0
[10.181152] Console: switching to colour frame buffer device 240x67
[10.188268] registered panic notifier
[10.188302] [drm] Initialized nouveau 0.0.15 20090420 for 0000:01:00.0 on minor 0

After few times of inactivity, this lines show up too:

udevadm settle - timeout of 180 seconds reached, the event queue contains:
/sys/devices/pci0000:00/0000:00:1f.1/host0/target0:0:1/0:0:1:0/block/sda (718)
/sys/devices/pci0000:00/0000:00:1f.1/host0/target0:0:1/0:0:1:0/block/sda/sda1 (719)
/sys/devices/pci0000:00/0000:00:1f.1/host0/target0:0:1/0:0:1:0/block/sda/sda2 (720)
/sys/devices/pci0000:00/0000:00:1f.1/host0/target0:0:1/0:0:1:0/block/sda/sda5 (721)
/sys/devices/pci0000:00/0000:00:1f.1/host0/target0:0:1/0:0:1:0/block/sda/sda6 (722)
/sys/devices/pci0000:00/0000:00:1f.1/host1/target1:0:0/1:0:0:0/block/sdb (731)
/sys/devices/pci0000:00/0000:00:1f.1/host1/target1:0:0/1:0:0:0/block/sdb1 (732)
done (timeout).
udevd[294]: worker [327] unexpectedly returned with status 0x0100

udevd[294]: worker [327] failed while loading '/devices/pci0000:00/0000:00:1f.1/host0/target0:0:1/0:0:1:0/block/sda'

udevd[294]: worker [317] unexpectedly returned with status 0x0100

udevd[294]: worker [317] failed while loading '/devices/pci0000:00/0000:00:1f.1/host0/target0:0:1/0:0:1:0/block/sdb'

What can I do to fix this?


UPDATE

I have downloaded /var/log/messages from that computer (It was bad file from live linux, not from the one installed on my computer, there isn't seems to be any related info/errors in the right "messages" file, I'm not sure it could help)

UPDATE2: I have run e2fsck on both of my ext partitions (sda), but exit code was 0 (no error)

UPDATE3: I just tried to "repair" filesystem using alternate superblock, I was successful but nothing changed :(. What more can I try?

share|improve this question
1  
It seems to be complaining that /dev/sda doesn't come up. That is your primary disk? Have you tried to boot in single user mode? A LiveCD/installation media as rescue, so any hash you might have made with the configuration isn't an issue? –  vonbrand Mar 14 '13 at 23:08
    
I have tried hiren's CD live linux, I was able to mount my primary disk. So the disk isn't broken, I dont know what may be wrong with it, filesystem seems to be ok as I am able to view and edit files. What means "single user mode" and what "hash" can I provide to help solve this? –  Buksy Mar 15 '13 at 8:26
    
I've just tried booting in single user mode, but I was unsuccessful –  Buksy Mar 16 '13 at 9:05
    
So, your computer boots fine with the snd-pscp module, but when you blacklist it, it hangs during boot? –  drs Apr 23 '13 at 13:43

2 Answers 2

Can you add root=/dev/sda to the kernel parameter add the boot screen? Maybe there is something wrong with your drive configuration. When you add root=/dev/sda the kernel will know where to search.

share|improve this answer

you must blacklist nouveau drivers. I don't wanna be the smartest guy in class. But you probably are trying to use Kali Linux. And this problem pcspkr' is new because now is created on debian. But problems with nouveau drivers are old, so read a little more about this on BackTrack forums.

share|improve this answer
    
I have tried blacklisting nouveau, but didnt helped, Im still unable to boot my pc (see linuxquestions.org/questions/… ) –  Buksy Mar 23 '13 at 18:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.