Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a problem of install RStudio Desktop verion on a CentOS 5 machine. Basically, RStudio Desktop needs QT4.8; however, I am not sure how to update my CentOS 5 QT4 to QT4.8. Otherwise, the Cmake can't go through.

share|improve this question
    
Another partial workaround is running R for Windows under WINE, although in one of the setups I had to use GUIs that were much worse than RStudio (in terms of user friendliness). Other than that, we use CentOS 6.4 and have no problems with RStudio. Generally, rolling out a clean workstation with CentOS 6 is much much better than sticking to 5.9 ('tis different with servers, of course). –  Deer Hunter Mar 14 '13 at 20:38
    
Thanks for your reply; however, if I ask our IT department to update my desktop to CentOS 6.4, will it affect all the packages, software that I have already installed on my CentOS 5 system? Or should I re-install all the software? If so, then that cost too much... But anyways, thanks! –  Samo Jerom Mar 15 '13 at 12:02

1 Answer 1

up vote 1 down vote accepted

Can't you use self-contained Zip/Tarball from http://www.rstudio.com/ide/download/desktop? You don't have to install it, just download it, unpack it and go to bin folder and run rstudio. It looks like you need to have R installed, but QT libraries are included.

share|improve this answer
    
Thanks very much for your reply. That was what exactly I tried before as well. However, I got the error message: > rstudio: error while loading shared libraries: libgio-2.0.so.0: cannot open shared object file: No such file or directory –  Samo Jerom Mar 15 '13 at 10:42
    
I am not sure where I can find this libgio-2.0.so.0 by googling it online :-( –  Samo Jerom Mar 15 '13 at 10:45
    
Tried to installed glib glib2 but still can't find this libgio-2.0.so.0 –  Samo Jerom Mar 15 '13 at 10:59
    
I haven't used CentOS, but in openSUSE, libgio-2.0.so.0 comes with libgio-2_0-0 package, not glib. Please try to find and install libgio-2_0-0 or libgio*. –  joon Mar 15 '13 at 13:57
    
No libgio for CentOS... shamed. I have no idea why research institutions always prefer to setup CentOS, which is a bad system overall compared to SUSE, Ubuntu... –  Samo Jerom Mar 15 '13 at 14:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.