Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

We have our postfix configured to handle mail for our websites. For every website we have configured a bounce handling user with

local_recipient_maps = hash:/etc/postfix/recipient_maps

The file recipient_maps looks like:

site1_bounce@our-domain.com          site1_bounce/
site2_bounce@our-domain.com          site2_bounce/
...

We're using lmtp for postfix to communicate with dovecot with local delivery:

local_transport = lmtp:unix:private/lmtp-dovecot

When one of our websites sends mail it uses the postfix VERP feature by using the senmail command options

/usr/sbin/sendmail -XV -t -i

All of this works nicely, and we're getting bounces in different IMAP folders.

By checking the reputation of our mail server I stumbled over one RBL that black lists our mail server, http://v4bl.org. If I understand the informations correctly the reason for this is because we fail 1 test that can be checked out here

http://multirbl.valli.org/fcrdns-test/

If I choose "test by sending an email" I'm getting 1 error, namely, the test program tries to send an email to our envelope RCPT TO address, that is e.g.

site1_bounce+testuser=testdomain.tld@our-domain.com

which obviously fails because we don't have a local mail account for every generated VERP address.

One real world case would be that a recipient mail server accepts a mail from our postfix and sends a bounce mail later to the RCPT TO address.

So how do we map those VERP addresses back to our bounce handling mail accounts? We tried our luck with

alias_maps = regexp:/etc/postfix/verp_alias_maps

with verp_alias_maps being:

/^site1_bounce\+.+@our-domain.com/       site1_bounce
/^site2_bounce\+.+@our-domain.com/       site2_bounce
...

but it appears as postfix ignores our ailas_maps file.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Use postfix config parameter "recipient_delimiter". Set it to "+".

recipient_delimiter = +

http://stackoverflow.com/a/5404399 - Allowing emails with a plus (+) symbol to land in the same Zimbra mailbox

http://www.postfix.org/postconf.5.html#recipient_delimiter

share|improve this answer
    
Thank you Andrzej A. Filip, that fixed the problem. –  Matthias Mar 14 '13 at 18:51
    
Welcome to Unix and Linux! Please don't just post a link as an answer, both because the linked site may be unavailable, and because as it is your answer doesn't show what it's about. Summarize the essential parts of the answer here, and provide the link for reference. –  Gilles Mar 14 '13 at 23:15
    
@Matthias If that answer solved your problem, please mark it as accepted by clicking the checkmark next to it. However, for the sake of future visitors, it would be better if the accepted answer contained the solution, rather than merely a link to a link to the solution. –  Gilles Mar 14 '13 at 23:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.