Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Recently added a new *.VDI image with Ubuntu 12.04 to my existing VirtualBox. The machine hangs with a "Waiting for network configuration" error, eventually times out after 60 seconds and boots in command line mode. How can I activate the GUI mode for this machine?

Some useful information:

cat /etc/network/interfaces

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0 
iface eth0 inet dhcp

ip link 
1: lo: <LOOPBACK,UP,LOWER_UP> ..
2: eth1: <BROADCAST, MULTICAST> ..

I tried to use the below command:

ifup eth0 

it fails with following error message:

cannot find device "eth0" Failed to bring up eth0 

ifconfig didn't show any eth* and I am confused now. Can anyone help?

share|improve this question
    
What network card does VBox emulate? The default is an Intel, which is supported by Linux/BSD/Solaris, I can testify for that. Try 'ifconfig -a'. –  schaiba Mar 14 '13 at 16:48
    
That useful info, is that from the guest or the host? that isn't clear to me –  Glenn Plas Mar 14 '13 at 16:53
1  
It shows an eth1, and you try to configure eth0.... –  vonbrand Mar 14 '13 at 17:02
    
@schaiba: ifconfig -a gives eth1 Link encap:Ethernet HWaddr 08:00:27:ee:25:3d and lo Link encap:Local Loopback just included the first line from the display. This is from guest os. –  Vipin Mar 14 '13 at 17:04
    
@vonbrand: yes, but I am not able to get ping www.unix.stackexchange.com fron the machine. –  Vipin Mar 14 '13 at 17:06

2 Answers 2

So you have a local VirtualBox install of Ubuntu 12.04 that doesn’t see a network connection? And I am assuming you want it to reach the outside world, correct? Have you checked your main network settings for the virtual machine in VirtualBox itself?

I setup my VirtualBox similarly to what is explained on Christopher Maier’s post here and it works great.

The key is to setup two adapters. The first adapter is Adapter 1 and that is set to NAT. And Adapter 2 to be a host-only adapter.

share|improve this answer

Check the content of /etc/udev/rules.d/70-persistent-net.rules file to get the names assigned to your network devices by udev. Usually, those should be eth0 for wired and wlan0 for wireless, but not necessarily. Then put the appropriate names into the /etc/network/interfaces file.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.