Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

This question already has an answer here:

When I press Ctrl + Alt + F1 the desktop environment disappears and a terminal window appears. Pressing Ctrl + Alt + F7 brings me back to DE.

This terminal is useful when the DE hangs for some reason and I need to kill a process or something.

However the keyboard typing speed in this terminal is so fast that its almost unusable.

Attempting to type sudo ps -ef | grep virtualbox often gets me suuudo pss -ef || grep virtuaalbox

I have two questions -

  • What terminal is this? Is it Xterm?
  • Could I reduce the keystroke speed to a more usable value, as in gnome-terminal?
share|improve this question
add comment

marked as duplicate by Stephane Chazelas, Mat, Kshitiz Sharma, manatwork, Chris Down Mar 14 '13 at 7:16

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

up vote 2 down vote accepted

What you get when you press Ctrl + Alt + F1 is not Xterm, or anything to do with X or your DE. It is called a TTY (a shortening of TeleType, see here for some history). The command you want is kbdrate. The -d option lets you set the delay before it starts repeating keys, and the -r lets you set the rate at which keys repeat after they've started. You need to run kbdrate as root. Also, not all settings are valid, see the man page for details.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.