Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm in Linux (if it's relevant: Fedora 17 x86_64, 3.6.11) and my laptop's PageUp key has gone ultrasensitive on me. I'd like to disable it (remap it to nothing at all) as I've never liked it where it is (right next to my up arrow keys).

I'm sure that I can use xmodmap to do it, but I don't even know where to start.

** EDIT **

I have read through the man page for xmodmap top to bottom. It is not useful for a beginner (makes a great reference for an experienced user, I assume, like the other man pages I use on a regular basis). My biggest problem is in understanding all the opaque terminology they've invented for it. I can see how to remap a single key in its various modified forms, but there's no "IGNORE THIS KEY COMBINATION" option that I've been able to find.

I'd like something like:

keycode 112 = NULL PAGE_UP

I'm pretty certain that either clear or remove might be the answers to my problem, but I can't find a good description of how to use them. The simplest tutorials indicate that clear isn't what I want (it's all about modifiers). And remove looks like an assignment not a removal

share|improve this question

migrated from superuser.com Mar 14 '13 at 3:22

This question came from our site for computer enthusiasts and power users.

    
But have you tried, eg any research? –  pnuts Jan 15 '13 at 2:56
1  
Yes I have indeed. –  Cpfohl Jan 15 '13 at 13:14

1 Answer 1

up vote 2 down vote accepted

My biggest problem is in understanding all the opaque terminology they've invented for it. I can see how to remap a single key in its various modified forms, but there's no "IGNORE THIS KEY

In your case "ignore this key" translates to "remap to nothing".
Open a terminal and run:

xmodmap -e 'keycode 112='

your PageUp key will suffer a sudden death.

Re-enable it with:

xmodmap -e 'keycode 112= Prior'

To permanently disable it add:

keycode 112=

to your ~/.Xmodmap

Test your config file:

xmodmap ~/.Xmodmap
share|improve this answer
    
Awesome, thanks so much. –  Christopher Pfohl Apr 8 '13 at 13:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.