Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have recently installed Fedora in my system. But I am facing some problem in ssh login from remote machine.

I am able to login in that system but every time its requires me to login using GUI in that system. So if I reboot that system then after rebooting I won't be able to login until I go to that system and enter the password in GUI login.

Here I have notice that system connection checkbox is disabled in my system. So why is this option disabled in my system?

enter image description here

Any help and suggestion will be appreciated.

Edit 1:

1) yeah sshd is running in both system

2) here is the output of `ssh -v login@machine' command

[root@localhost src]# ssh -v login@192.168.1.100
OpenSSH_5.6p1, OpenSSL 1.0.0j-fips 10 May 2012
debug1: Reading configuration data /root/.ssh/config
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to 192.168.1.100 [192.168.1.100] port 22.
debug1: Connection established.
debug1: permanently_set_uid: 0/0
debug1: identity file /root/.ssh/id_rsa type -1
debug1: identity file /root/.ssh/id_rsa-cert type -1
debug1: identity file /root/.ssh/id_dsa type -1
debug1: identity file /root/.ssh/id_dsa-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.6
debug1: match: OpenSSH_5.6 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.6
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host '192.168.1.100' is known and matches the RSA host key.
debug1: Found key in /root/.ssh/known_hosts:23
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic,password
debug1: Next authentication method: publickey
debug1: Trying private key: /root/.ssh/id_rsa
debug1: Trying private key: /root/.ssh/id_dsa
debug1: Next authentication method: password
login@192.168.1.100's password: 
debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic,password
Permission denied, please try again.
share|improve this question
2  
This is really confused. Do you have sshd running on the machine? What does ssh -v login@machine gives you? What do the log files say? Note that the GUI is utterly irrelevant to ssh and that the network configuration has nothing to do with ssh -- apart from enabling network. –  Sardathrion Mar 13 '13 at 11:07
    
@Sardathrion i am able to do ssh login after starting that system, but i need to provide the password everytime to that system.why system connection checkbox is disable in my system ? –  juned Mar 13 '13 at 11:26
    
You need to set up an ssh agent or ssk keys (in ~/.ssh/authorize_keys2) if you do not wish to type your password all the time. The system connection check box has nothing to do with ssh. It is a configuration of your network settings. Might I suggest you read up about networking in Linux and ssh in general. It will help you in the long run. –  Sardathrion Mar 13 '13 at 11:34
1  
The question does not represent the real problem, do you want to connect password-less to SSH? –  ghm1014 Mar 13 '13 at 18:54
1  
Is that ssh -v trace from when you can log in, or when you can't? When you can't log in, do you get a password prompt? Is this a wired or wifi connection? Is your home directory encrypted? Post your /etc/sshd_config (or /etc/ssh/sshd_config, whichever it is). –  Gilles Mar 13 '13 at 21:08

2 Answers 2

You need to set up ssh public key authentication if you do not want to type your password all the time.

As a side note, you should never use root as your personal account. This is a terrible practice that will bite you sooner rather than later. If you are attempting to login as root, then most sshd sane configurations will not allow that. This is right behavior.

share|improve this answer
    
its not personal account, i am setting up all this thing on my server. and finally my problem is solved by setting ONBOOT=yes in /etc/sysconfig/network-scripts/ifcfg-p19p1 file. –  juned Mar 14 '13 at 6:20
    
@juned: This has nothing to do with ssh or what I understood your problem to be. –  Sardathrion Mar 14 '13 at 8:42
    
ohh i see but why now everything works fine –  juned Mar 14 '13 at 8:48
    
@juned: What works fine? ... You need to be more precise about what you are asking. Currently, I have no idea what you are trying to achieve. I thought it was passwordless ssh authentication. It appears that now you are talking about setting your network interfaces. The two have nothing to do with each other in as much as ssh requires some networking. Anyhow, 'nuff said. –  Sardathrion Mar 14 '13 at 9:10

Have you tried with another user instead of root user ? In latest fedora there is restriction for root. You can change it from : /etc/ssh/ssh_config

share|improve this answer
    
You can but should not. Allowing root access to ssh is like leaving you car unlocked with the keys in the ignition... –  Sardathrion Mar 13 '13 at 14:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.