Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have 2 nvidia cards with three monitors Left (0), Middle (1), and Right (2). I have to use xinerama to make them all one desktop because xrandr only joins 0 and 1, leaving 2 as a separate desktop. My understanding is that xrandr can ONLY join two desktops, which is why I am using xinerama.

After MUCH trouble, I have three displays, all one desktop. But, there is a problem. Screens 0 and 2 work fine. Screen 1 is double-wide. It scrolls left-right as I mouse across it. The left half of the display is a mirror of screen 0. The right half of the display is what should be on screen 1. I've tried to make an image that shows what it is like:

The middle monitor shows screen 0 and screen 1

I don't understand what can cause one and only one screen to mirror another screen. Further, how does it mirror one screen on half the display, but not the other half?

For reference, my xorg.conf is reduced to the bare minimum. My layout section only has Screen0 0 0, Screen1 Right of Screen0, Screen2 Right of Screen1, and xinerama on. My device sections only have the PCI address of the cards. My screen sections only have the device setting. So, there isn't a setting that would cause this, but I figure I'm missing a setting that stops it - if I just knew what that setting was.

share|improve this question
    
The solution to this problem is to explicitly disable closing with option "clone" "0". With cloning off, it doesn't try to clone screen0 and screen1. –  kainaw Mar 12 '13 at 13:33

1 Answer 1

What I could not see is that Screen1 was actually a clone of Screen0. When the mouse hit the edge of monitor0, it jumped to monitor1 instead of scrolling screen0 on monitor0. Then, when it hit the edge of monitor1, it scrolled screen1. That made it appear that screen1 had more display than screen0 when they were, in fact, just clones. So, the solution was to disable cloning by adding:

Option "clone" "0"
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.