Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm new to the whole Linux thing. I have a Linux server up and running and have been using this guide as a help. I have an issue with shared drives. My Windows machines can see them but cant write to them says I don't have permission. I'm completely lost.

Can anyone help? Let me know if I should post Samba configs. I'm running Windows XP, 7 and 8 and Ubuntu server.

share|improve this question
    
I should say im using webmin to configure everything –  Alastair Cupples Mar 11 '13 at 9:11
add comment

1 Answer 1

Samba share permissions are as held in it's configuration file smb.conf [/etc/samba/smb.conf]. Here you can set permissions such as:

  • guest ok: If set to yes, the users will have access to the - share without having to enter a password. This can pose security risk.
  • writeable: Specifies users should have write access to the share.

All of these settings use a simple yes or no setting.

Creating a shared directory to share your music and calling it music. Edit your smb.conf and add the following:

[music]
path = /home/shared/music
writeable = yes

If you are sharing the files on a large network and you don't want everyone to be able to write to the folder. You can also use write list and give users their own username and password instead of having it globaly writeable. You would define this as follows:

[music]
path = /home/shared/music
write list = mom dad fred

giving only those users the ability to write to the folder. There are many more options you could go with but this is the most straight forward. Check here for a more detailed tutorial on setting up permissions with shares in samba.

NOTE: Once you're done editing the permissions make sure to restart Samba to apply the changes.

share|improve this answer
    
thanks for your help. I have already made sure they are set to writable and guest ok. its just for my home so don't really need to worry about security. any other ideas? –  Alastair Cupples Mar 11 '13 at 10:38
    
You've restarted the Samba server as well ? Also, the permissions set in the samba configuration does not take priority over the filesystem. So if you've done everything else set the permissions to the shared folder to 777. chmod -R 777 /home/shared/movies and restart the server and retest. –  cinelli Mar 11 '13 at 10:57
    
yeah rebooted samba server. so in my case it would be chmod -r 777 /media/films ? –  Alastair Cupples Mar 11 '13 at 11:09
    
If that's the actual directory then it would be owned by root and only root would have permission to do anything to it. So yes, you'll have to make it globally read & writable. –  cinelli Mar 11 '13 at 11:14
    
awesome :) ill try it when I get home and update you guys. Cheers for all the help I really appreciate it. –  Alastair Cupples Mar 11 '13 at 11:46
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.