Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Scrollability of text in some terminals:

       | tty | xterm | urxvt | guake | terminator
screen |  Y  |   Y   |   Y   |   Y   |     Y
tmux   |  N  |   N   |   Y   |   N   |     N

I notice in this answer that scrolling doesn't work when using tmux. But I can scroll in urxvt. How can I have that behaviour in other terminals?

share|improve this question

3 Answers 3

up vote 4 down vote accepted

Add set -g terminal-overrides "xterm*:smcup@:rmcup@" to your tmux config and restart tmux. If you are not using a terminal matching 'xterm*' you'll have to change it of course.

share|improve this answer
Unfortunately this breaks tmux set-titles setting/feature: the terminals window title does not update anymore. – blueyed May 6 '14 at 13:22

Try setting the alternate-screen setting to off.

share|improve this answer
You mean adding setw -g alternate-screen off in /etc/tmux? That doesn't make any difference. – phunehehe Feb 1 '11 at 5:04

Use tmux set -g mode-mouse on

I use an alias "tn" with this (having it as the default in my .tmux.conf didn't work for me, some issue, tl; dr;)

alias tn='tmux set -g mode-mouse on'
share|improve this answer
ran into this, and man pages mentioned it only loaded config file when server first starts, and suggested reloading the tmux.conf file with the source-file command. That worked for me and I can use config file as opposed to the alias trick here. – Alan Nov 19 at 18:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.