Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

There is too big delay when logging in with xscreensaver in OpenSUSE 12.2

--- Actual delay is 10 seconds, but not found anywhere in configs

Already done:

  • checked pam timeout in login.defs (3 seconds)
  • no pam_faildelay.so options in any of /etc/pam.d/ files
  • checked login settings via YaST (uses login.defs so useless)
  • played with pam_faildelay.so delay parameter in /etc/pam.d/login, /etc/pam.d/commom-auth-pc files
  • .xscreensaver config in /home/
    timeout:    0:10:00
    cycle:      0:10:00
    lock:       True
    lockTimeout:    0:00:00
    passwdTimeout:  0:00:05
    visualID:   default
    installColormap:    True
    verbose:    False
    timestamp:  True
    splash:     False
    splashDuration: 0:00:05
share|improve this question
    
I have the same problem. It existed in 12.1 as well. –  choroba Mar 9 '13 at 16:47
1  
try to strace or ltrace it –  Carlos Campderrós Mar 12 '13 at 9:12
add comment

1 Answer

The passwdTimeout (class Time) parameter determines the wait time between failed passwords.

from the man page:

Options to xscreensaver are stored in one of two places: in a .xscreensaver file in your home directory; or in the X resource database. If the .xscreensaver file exists, it overrides any settings in the resource database.

The only conceivable error here is that the daemon is not running as your user. It could also be that there is a bug in the package for your distro, in which case you could build from source.

share|improve this answer
    
I've already played with passwdTimeout option from .xscreensaver –  Ribtoks Mar 18 '13 at 11:44
    
I know you have. I'm saying your program or the way it is executed is the issue. Setting that value has the desired effect with xscreensaver 5.15 on Gentoo. –  Ярослав Рахматуллин Mar 18 '13 at 12:11
    
passwdTimeout seems to indicate how much time you have to enter the password (setting it to lower numbers speeds up the vertical bar), not the delay on wrong password. –  choroba Jan 20 at 22:20
    
See also unix.stackexchange.com/q/40954/13792 –  choroba Jan 20 at 22:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.