Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a wireless interface Intel 1030 on a Dell XPS 15 laptop. lspci says:

03:00.0 Network controller: Intel Corporation Centrino Wireless-N 1030 [Rainbow Peak] (rev 34)

Recently I noticed that the error message iwlwifi 0000:03:00.0: fail to flush all tx fifo queues appears in dmesg, then my WLAN is very slow (to the point that names will fail to resolve 90% of the time). and I can't connect to any network other than the one I'm currently connected to (both iwlist wlan0 scan and NetworkManager or wicd don't show any other networks) (edit: this last problem was a false alarm)

The only cure is disabling/enabling the wireless network. Here I find that it might be related to suspend, however it appears even after a fresh boot or when under heavy traffic (e.g. downloading a torrent).

Forcing the card to use only 802.11g (11n_disable=1 option when loading the module) helps somewhat.

Any clues? It happens both in Ubuntu 12.10 (kernel 3.5), openSUSE 12.3 (kernel 3.7) and Arch Linux (kernel 3.7.10 or 3.8.2-ck).

share|improve this question
    
Try adding bt_coex_active=0 to your iwlwifi options, see if that makes any difference. –  don_crissti Mar 17 '13 at 16:26
    
Doesn't help, sadly. –  Renan Mar 18 '13 at 22:30
    
what is the output of lscpi in reference to the wireless device in question? –  cinelli Mar 22 '13 at 17:25
    
03:00.0 Network controller: Intel Corporation Centrino Wireless-N 1030 [Rainbow Peak] (rev 34) –  Renan Mar 22 '13 at 17:26

3 Answers 3

up vote 4 down vote accepted
+100

Arch Linux no longer uses wlan0 or eth0 when it comes to naming the wireless devices. The command ip a will display the list of devices in a numbered list with their names. The only way that the old network devices names are used is if the device can not supply a suitable name for the device or if you have a udev rule in place to point the devices back to their old names. Once you have the device names correct then use those names with iwlist or whatever network manager that you're using.

I'm assuming that you're using Arch Linux since the link you've provided is to the Arch Linux forums.


Create to following file and add the following settings inside of it.

/etc/modprobe.d/iwlwifi.conf (file to be created)
-------------------------------------------------
options iwlwifi 11n_disable=1 
options iwlwifi bt_coex_active=0 

Once completed save and exit the text editor and now just to be safe check the HOOKS= array inside /etc/mkinitcpio.conf and make sure that the modconf is in the array. If it isn't then add it and and save and exit the text editor. You will then have to rebuild the initramfs and reboot.

If you're unsure on how to rebuild the initramfs. mkinitcpio -p linux

share|improve this answer
    
If you're trying to use both cards at the same time. Then one of the wireless cards would have to be placed in managed mode, while the other is in monitor mode. –  cinelli Mar 22 '13 at 16:36
    
The problem is distro-agnostic (it happens in all distros I've tried - Ubuntu w/kernel 3.5, Arch Linux w/kernels 3.7 and 3.8 and openSUSE w/kernel 3.7). –  Renan Mar 22 '13 at 16:51
    
What type of network card are you using? What's the output of lspci in reference to the device? –  cinelli Mar 22 '13 at 17:02
    
updated question with this information –  Renan Mar 22 '13 at 17:09
1  
Create and add the following to /etc/modprobe.d/iwlwifi.conf options iwlwifi 11n_disable=1 options iwlwifi bt_coex_active=0 Then make sure to check /etc/mkinitcpio.conf and make sure that modconf is added to the HOOKS="" array. If it isn't add it and then rebuild the initramfs and then reboot. –  cinelli Mar 22 '13 at 17:10

Unless you're okay with running at g speeds, there are a couple more options you could try:

  • swcrypto=1
  • wd_disable=1

I have an Intel Centrino Wireless-N 2230 with similar issues, and wd_disable=1 fixes it for me. I don't have to use it with recent kernels though.

share|improve this answer

It's related to your wireless options, some of wireless cards have many feature which incompatiable with wake up option. however, if i have your problem, compile a new kernel such as 3.8.2 milestone.

share|improve this answer
    
I have 3.8.3. It still happens there. –  Renan Mar 20 '13 at 18:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.