Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I used dd if=archlinux-2010.05-core-x86_64.iso of=/dev/sdb to create an installation image on a USB stick and I'm getting a blank screen soon after boot-up. The last message I saw is:

Waiting for UDev UEvents to be processed...

What am I to do?

[note] Am using a TravelMate 6592: Core 2 Duo T7500 2.2GHz processor.

share|improve this question
1  
I am facing a similar issue, though I used unetbootin to create my bootable usb stick –  Shrikant Sharat Feb 13 '11 at 4:12
    
Try getting to a console. Ctrl-Alt-F1. If that works, boot worked, and X is the problem. If not, your system hasn't booted properly. If the former, the next thing is to look at the X log in /var/log/Xorg.0.log or similar. –  Faheem Mitha May 5 '11 at 18:37
    
@FaheemMitha: This problem occurs at installation stage. –  Tshepang May 5 '11 at 18:39
    
Is it trying to boot up into X? If, so try booting into console mode. This is an option for Debian. I don't know if installers of other distributions support it. (Sorry, didn't realise this was an old question. Perhaps it is no longer relevant?) –  Faheem Mitha May 5 '11 at 18:47
    
@FaheemMitha: It's the very first installer bootup, before I can do anything at all. –  Tshepang May 5 '11 at 18:56
show 1 more comment

3 Answers

Apparently, with this model, the parport_pc module causes udev to hang[1]. You might have to blacklist this module to successfully install Arch.

Adding disablemodules=parport_pc to your kernel line[2] should allow udev to proceed.

[1] http://www.mail-archive.com/arch-general@archlinux.org/msg11658.html

[2] When the iso boots and you see the grub menu, press e to edit, then add that string to the end of the kernel line. Press Enter then b to boot.

share|improve this answer
add comment

Try adding nomodeset and a low resolution like vga=771 to the kernel line in GRUB.

share|improve this answer
    
I get the same, except that at least I don't get a blank screen. That last line remains at [BUSY]. –  Tshepang Jan 31 '11 at 19:57
add comment

Try adding video=SVIDEO-1:d OR i915.modeset=0 It might help if you have integrated Intel video.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.