Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am writing a quick script to read user input and put into commands of a couple different programs. I'm using xterm -e to open a terminal for each separate program.

The script is working fine, but each time xterm -e is executed, an error message is displayed:

Warning: Tried to connect to session manager, None of the authentication protocols specified are supported

Any ideas on how to stop this from displaying?

share|improve this question
up vote 4 down vote accepted

xterm uses the $SESSION_MANAGER environment variable to find out how to contact the X session manager.

In your case it seems to be unable to authenticate to it. Possibly, that script is started in the current session but as a different user.

Anyway, you don't have to report to a session manager so you can as well unset that variable to make the error message go away:

unset SESSION_MANAGER

Or if your env supports the non-standard -u options, start xterm as env -u SESSION_MANAGER xterm ....

share|improve this answer
    
That works! Thank you. – Synner Mar 6 '13 at 22:16

Actually, xterm does not directly use the SESSION_MANAGER variable. That is used in the Xt and SM libraries.

A more direct method of disabling the session manager feature is found in the xterm manual, first in command-line options:

-sm This option, corresponding to the sessionMgt resource, indicates that xterm should set up session manager callbacks.

+sm This option indicates that xterm should not set up session manager callbacks.

and then in application resources:

sessionMgt (class SessionMgt)
If the value of this resource is "true", xterm sets up session manager callbacks for XtNdieCallback and XtNsaveCallback. The default is "true".

Since these features were introduced in patch #169 (2002), it is likely that they are available.

share|improve this answer

You can ignore it with:

xterm -e 2> /dev/null
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.