Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a Lenovo W530 running Arch with kernel 3.79 (for bumblebee) and laptop-mode is configured properly and running. It has one SSD (sdb) and one harddisk (sdb). The sdb disk has two lvm-volumes: one is storage and one is swap.

The problem is that the harddisk keeps getting polled and lsof outputs nothing regarding the lvm volumes when these are mounted. When I mount sdb2 (a NTFS partition) the hd spins down correctly; It seems to have something to do with LVM.

All worked fine (i.e. the harddisk spinned down properly) just before I removed two lvm volumes and replaced them with a single volume (lv_storage). I removed them using lvremove and added one using lvcreate.

The harddisk-activity-indication light blinks every second or so. Hdparm can spindown the harddisk (until it gets polled again).

EDIT: problem seems to be the jdb2 journaling service. IOtop reveals that the process ([jdb2/dm-1-8]) is keeping the hd awake. However I only have dm-0(lv_swap) and dm-1 (lv_filestorage) and there are no files residing on the lv_storage volume.

Data:

lsblck ->

NAME                             MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda                                8:0    0  59.6G  0 disk 
|-sda1                             8:1    0   300M  0 part 
|-sda2                             8:2    0   100M  0 part /boot/efi
|-sda3                             8:3    0   128M  0 part 
|-sda4                             8:4    0  28.8G  0 part 
`-sda5                             8:5    0  30.3G  0 part /
sdb                                8:16   0 465.8G  0 disk 
|-sdb1                             8:17   0 195.3G  0 part 
| |-VolGroup01-lv_swap (dm-0)    254:0    0     8G  0 lvm  [SWAP]
| |-VolGroup01-lv_storage (dm-1) 254:1    0   150G  0 lvm  
| `-VolGroup01-lv_test (dm-2)    254:2    0     1G  0 lvm  
`-sdb2                             8:18   0 270.5G  0 part  

uname -a ->

Linux w530 3.7.9-2-ARCH #1 SMP PREEMPT Mon Feb 25 12:04:25 CET 2013 x86_64 GNU/Linux

lvdisplay ->

--- Logical volume ---
LV Path                /dev/VolGroup01/lv_swap
LV Name                lv_swap
VG Name                VolGroup01
LV UUID                HoElDQ-OZ3z-XkGX-dBE1-qVnD-NEgB-4G7D7S
LV Write Access        read/write
LV Creation host, time archiso, 2013-02-27 20:17:33 +0000
LV Status              available
# open                 2
LV Size                8.00 GiB
Current LE             2048
Segments               1
Allocation             contiguous
Read ahead sectors     auto
- currently set to     256
Block device           254:0

--- Logical volume ---
LV Path                /dev/VolGroup01/lv_storage
LV Name                lv_storage
VG Name                VolGroup01
LV UUID                iIvwkz-1bph-pCHs-8QOw-F0J9-0RRA-ea783w
LV Write Access        read/write
LV Creation host, time archiso, 2013-03-06 03:10:55 +0000
LV Status              available
# open                 0
LV Size                150.00 GiB
Current LE             38400
Segments               1
Allocation             inherit
Read ahead sectors     auto
- currently set to     256
Block device           254:1

/etc/fstab ->

# /dev/mapper/VolGroup01-lv_storage
UUID=1b01a1dd-6ea9-484c-933c-e581767ad4b9      /mnt/storage    ext4       
rw,relatime,data=ordered        0 2

# /dev/mapper/VolGroup01-lv_swap
UUID=66afafb1-5f90-41c0-967e-343a8d269581       none            swap
defaults        0 0
share|improve this question
1  
I would blame the filesystem first. What filesystems do you have on the hard disk? Also, if you've activated that swap area, it's likely to be used. –  Gilles Mar 6 '13 at 23:31
    
All of the used filesystems are ext4. The swap has been activated (which is stored on the hd). The swap doesnt keep the hd awake (mind that the system currently has 8GB). It really must have something to do with the fact that I removed two volumes, and added one. I'll edit the post for clarity –  BTZ Mar 6 '13 at 23:45
    
Do iotop and powertop show anything useful? –  Gilles Mar 6 '13 at 23:48
    
Never used iotop: thanks! And yes it did: jdb2 seems to be the problem. Apparently it wants to do some journalling stuff every second -> why? –  BTZ Mar 7 '13 at 0:03
    
Sollution found! Will post it within the hour because StackExchange wont allow my to answer my own question within 8 hours -> it had to do with jdb2 not finishing the initial build up of journals and a low commit time. Thanks for the tip on iotop! –  BTZ Mar 7 '13 at 0:36

1 Answer 1

It isn't LVM, it is the ext4 filesystem. By default it commits the journal to disk every 5 seconds. You can correct this using the commit mount option and setting it to a longer interval. See man mount.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.