Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to install a library on my debian machine and it requires a python version above 2.6.6-7. The machine had installed the version 2.5.2-3, so I installed python 2.7.

When I run python -V, the output is "Python 2.7", but when I try to install the library, it outputs "Version of python on system is 2.5.2-3.". How can I solve this?

The library I'm using is paramiko, in order to use ssh communication. If, instead of solving the above, you could suggest another library which works with python 2.5, it would be apreciated as well.


share|improve this question
Lenny has been EOL for over a year. – jordanm Mar 4 '13 at 15:41
How did you install python 2.7? I suspect you installed it to /usr/local which is why your library cannot find it. – vh4x0r Mar 5 '13 at 13:27

Assuming you install from pypi you have to make sure that your easy-install or pip uses the right version of Python, e.g. by using:

pip-2.7 install paramiko

If you install from an extracted source file, I recommend you explicitly use python2.7 or use the full path to the python2.7 executable.

sudo python2.7 setup.py install
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.