Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

it works fine mounting manually from the cli

but when running

sudo mount -a 

after editing the fstab im getting errors. It seems right to me, any one have a suggestion.

my fstab is:

# /etc/fstab: static file system information.                                                       
#                                                                                                   
# Use 'blkid' to print the universally unique identifier for a                                      
# device; this may be used with UUID= as a more robust way to name devices                          
# that works even if disks are added and removed. See fstab(5).                                     
#                                                                                                   
# <file system> <mount point>   <type>  <options>       <dump>  <pass>                              
proc            /proc           proc    nodev,noexec,nosuid 0       0                               
# / was on /dev/sda1 during installation                                                            
UUID=31c241fa-8ce7-4ddf-a11b-c1bb7214b9ff /               ext4    errors=remount-ro 0       1       
# swap was on /dev/sda5 during installation                                                         
UUID=f6adc6f2-a8ac-46cc-a167-fd5bdb985ca7 none            swap    sw              0       0         
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0                          

//megaboxy/inetpub /mnt/megabo cifs username=admin, password=passwd 0 0                 
//megaboxz/inetpub /mnt/megab cifs username=admin, password=passwd 0 0                 
//10.0.0.15/Share  /mnt/CodeS cifs username=admin, password=passwd 0 0                
//210.0.0.1/inetpub   /mnt/webse cifs username=admin, password=passwd 0 0                
//10.0.0.120/Kabura-Projects  /mnt/Projects  cifs username=admin, password=passwd 0 0     
share|improve this question
    
Probably network failure –  warl0ck Mar 3 '13 at 14:27

2 Answers 2

up vote 7 down vote accepted
//megaboxy/inetpub /mnt/megabo cifs username=admin, password=passwd 0 0
                                                   ^ this is a problem

You can't put spaces between the options. Remove that and that error should go avay.

share|improve this answer
    
ty whitespace deamon –  Darkmage Mar 3 '13 at 14:44

Add noauto option for all cifs system, and execute mount -a -t cifs after network service.

As you didn't mention your distro, this step could vary.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.