Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

This got closed on AskUbuntu because it wasn't Ubuntu enough for them.

I don't have any WLAN connections set up, and I always connect via Ethernet cable. However my computer has a small light on it that flashes to indicate network activity. For some reason this light keeps flashing, at extended random intervals, which is very annoying. I remember that I disabled it somehow on my old partition (Ubuntu, Mate), but I'm not seeing an option for it now.

Added: since asking I found an answer to the LED problem here: "Wireless indicator light flashing for activity on laptop keyboard" but I would feel slightly better knowing that I solved the source of the problem and not just the symptom.

Then I tried sudo rfkill block all. Will that solve it permanently? Is there a better way?

share|improve this question
    
Remove the firmware and/or blacklist the relevant module... –  jasonwryan Mar 2 '13 at 20:37
    
I don't know how to do that. –  Wutaz Mar 3 '13 at 0:05
    
It depends on your hardware (a vital detail you omitted from your question). See the Arch Wiki Wireless page. –  jasonwryan Mar 3 '13 at 0:36
add comment

1 Answer

up vote 0 down vote accepted

I believe Mint is running NetworkManager, and that's what connects your wireless network.

Edit your wireless connection profile, there's an option called Automatically connection, disable that.

share|improve this answer
    
Yes, I have NetworkManager. The documentation for it is a huge mess. Does <code>sudo nmcli nm wifi off</code> do what I want? Because nothing in /etc/NetworkManager changed when I ran it. –  Wutaz Mar 3 '13 at 19:05
    
Nevermind, I found the config in /var. Just when I think I'm starting to figure Linux out, it turns out to be even more screwed up than I thought. Thanks anyway. –  Wutaz Mar 3 '13 at 19:08
    
@Wutaz no need to run nmcli, just open nm-connection-editor to edit that –  warl0ck Mar 3 '13 at 23:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.