Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

As far as my memory goes, the map 'Desktop' contains the files which are shown on your desktop. However, my desktop is empty, while having files present in the map.

Yes, I mostly prefer an empty desktop, but it seems strange to me to be unable having anything on the desktop. And sometimes it just comes in handy to have certain files close.

So, my question is: How to enable having files on my desktop again?

I am using Debian Wheezy with Gnome 3.

Edit: I am not interested in installing different desktop environments, just in a solution to get this working in Gnome3.

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

Ok, it seems I just didn't search at all places.
In Advanced Settings, under the tab Desktop, there is the option 'Have file manager handle the desktop'. In case this is on, the file manager handles the desktop, and with that, the files on the desktop, enabling one to put files onto it. When this is off, as I had it, this is not possible, and one can panic for quite a long time about it.

share|improve this answer
add comment

Empty desktop is show when desktop is somehow disabled. Try installing another desktop environment like LXDE, it will surely show your files.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.