Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to open mplayer to play video without any terminal output using this:

mplayer -msglevel all=-1 /path/to/video

also:

mplayer -really-quiet /path/to/video

but it doesn't make it completely silent! and these are printed to output:

[flv @ 0x9a5d100]Estimating duration from bitrate, this may be inaccurate
[ass] Init
[ass] Updating font cache

How can I make mplayer completely silent?

Thanks

share|improve this question
up vote 2 down vote accepted

Try this: mplayer file > /dev/null 2>&1

share|improve this answer
    
I hoped it as an option; but this does the work too; – RYN Mar 1 '13 at 0:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.