Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

The title basically says it all - in Vim, my tab's show up as ^I, and I'm wondering if anybody knows why this might be. This is especially annoying when using :o to open a file, as the autocomplete does not function. I've looked all over but haven't been able to find anything, it even occurs with a blank .vimrc file. Is there a setting that would cause this, or a way I can remap the key to get it to function properly?

share|improve this question
add comment

1 Answer

If I read you correctly, you are talking of autocompletion in command mode when e.g. edit a file.

The section "cmdline-completion" of Vim manual says:

The 'wildchar' option defaults to (CTRL-E when in Vi compatible mode)

You should check this option.

OTOH, if :o means "open" command, it's obsolete and not recommended, and I'm wondering why do you use it. Really it's not to open a file, it's to enter visual mode.

If I understood you in a wrong way, please elaborate your question with more details. Currently it's too ambiguous.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.