Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just finished installing Fedora 18 and out of the box I noticed that it recognizes my IMON/MCE Remote control. I have had to make some changes to the rc_keymaps/imon_mce file to remap some of the keys, but it is pretty accurate.

However, when I use the remote with XBMC, I see that I sometimes get multiple presses instead of just one. For instance, if I press the down arrow once quickly, it will scroll down several lines very fast before stopping.

I've done a little searching online and have seen a lot of talk about Lirc, and the need to ensure that only Lirc is decoding the keypresses and not both Lirc and the kernel. However, from what I understand Lirc is already built into the kernel, so I am a little confused.

If I check which protocols are listening, I see only rc-6:

# cat /sys/class/rc/rc0/protocols 

What do I need to do to fix this problem?

Additionally, when I modify the imon_mce file, what service do I need to restart in order to reread the new file? I know I can force it using ir-keytable, but I presumed that there must be some service that loads up upon bootup.

share|improve this question
With Fedora being at 20 right now, and Fedora 21 due in October, I'm not sure this question is of any significance anymore. – polemon Aug 7 '14 at 5:07

Yes & no. You might need to install it separately and likely configure it as well.

$ sudo yum install lirc irc-remotes

I would also go through the LIRC tutorial on MythTV's website, titled: LIRC. Several of the drivers for certain remotes have been moved into the kernel. The MCE remote you're using if it's using USB, then it's likely one of them that uses this driver, mceusb.

From my experience the toughest part with setting up remotes is in configuring them.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.