Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I setup the FTP server on Machine A and created the YUM repo. And placed following contents in it.

#vi rhel-localftp.repo

name=bla bla bla
baseurl=file:///var/ftp/pub/Server(RPMs are under Server folder)

then installed httpd everything worked fine on Machine A.

Now turn of Machine B

I created the repository to access the RPMs from Machine A and contents are

#vi remoteftp.repo

name=bla bla bla

and then i tried to install package and it gave me this error

Note: There is no Firewall in between them

enter image description here

Do i have to install FTP server also on Machine B

share|improve this question
Do you have repodata/repmod.xml in Server directory? – pbm Feb 26 '13 at 20:33
Yes it is there.... /etc/ftp/pub/Server/repodata/repmod.xml – OmiPenguin Feb 27 '13 at 8:05
Is the FTP server started on machine A? – Jenny D Feb 27 '13 at 9:15
Damn, something is wrong with FTP server itself. It was running but when I restarted everything started working. – OmiPenguin Feb 27 '13 at 9:27

Since default home directory for ftp is /var/ftp/pub so there is no need to provide "/var/ftp" in "baseurl" parameter.

baseurl=  # WRONG

baseurl=          # Correct

Also make sure , you are able to connect ftp server , so you can just check using ftp server-ip to check connectivity.

share|improve this answer
Ok this time i just used baseurl= but got the same error – OmiPenguin Feb 27 '13 at 7:55
are you able to browse same ftp url from your browser in client end ? – Rahul Patil Feb 27 '13 at 8:30
No not even from Browser. I tried both and but no use – OmiPenguin Feb 27 '13 at 9:19
Rahul, there was problem with the FTP server itself I restarted it now its working. But thanks for giving me correct information about baseurl and how to use it. – OmiPenguin Feb 27 '13 at 9:29

have you tried yum-pull it might work.

share|improve this answer
Please avoid link-only answers. Provide enough context to answer the question. Furthermore, yum-pull is a tool for mirroring repositories, while according to the question, the OP wants machine A to function as the package source for machine B, not mirror the repository on B. The error message in the screenshot and the comments indicate the problem was with the FTP configuration on machine A. How exactly would yum-pull help in this case? – Thomas Nyman Oct 14 '13 at 5:06
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – Anthon Oct 14 '13 at 5:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.