Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

In Linux, I'm partitioning two disks for RAID1 with fdisk. The first disk partitioning succedes, but the second fail because the raid starts automatically and occupy also the second disk (why? it should have a different UUID).

How to temporary disable RAID autodetect? I guess there's a switch under /proc/sys filesystem.

I know it's possible to solve the problem in other ways, like removing RAID information from the disks with mdadm --zero-superblock but I want to know if it's possible to disable RAID autodetect without rebooting the system with raid=noautodetect nomdadm in kernel parameters.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.