Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have an old laptop where I installed Debian along with a samba server which I am using to share read-write access to 4 external hard drives, which I use to stream my media from.

All works fine, except for when the other 3 drives have spun down and a request is sent to a file on one of them. The file system seems to block all access to any device until the drive has spun up.

So, my question is, is it possible to prevent the blocking from occurring while the drive is spinning up?

share|improve this question

put on hold as off-topic by psusi, slm Dec 16 at 20:13

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – psusi, slm
If this question can be reworded to fit the rules in the help center, please edit the question.

    
I'm getting similar issues with slow USB1.1, what type of connections are you using? Have you tried hdparm -s ? –  Grizly Feb 27 '13 at 1:54
    
I am using USB 2.0, and achieving full speed. I just tried hdparm -s, and it is returning -s: bad/missing powerup-in-standby value (0..1), and given it is stating the dangers associated with using it, could you give me a bit of background? –  cgoddard Feb 27 '13 at 2:19
    
it is supposed to turn off the standby mode.. although can be dangerous of course, I assumed you would read the man page linux.die.net/man/8/hdparm –  Grizly Feb 27 '13 at 2:25
    
I did, but TLDR if i'm honest. I did use the tool that came with the drives to turn off the drives standby before, but I did have some concerns about leaving the drives on, so I disabled the option –  cgoddard Feb 27 '13 at 2:31
1  
Do you use a "recent" kernel? Are you using RAID on your disks? You could trying installing the Debian squeeze-backports 3.2 kernel. –  Totor Apr 9 '13 at 23:57

1 Answer 1

Really, the hdparm -s parameter should not be messed with, as explained in the manual

Enable/disable the power-on in standby feature, if supported by the drive. VERY DANGEROUS. Do not use unless you are absolutely certain that both the system BIOS (or firmware) and the operating system kernel (Linux >= 2.6.22) support probing for drives that use this feature. When enabled, the drive is powered-up in the standby mode to allow the controller to sequence the spin-up of devices, reducing the instantaneous current draw burden when many drives share a power supply. Primarily for use in large RAID setups. This feature is usually disabled and the drive is powered-up in the active mode (see -C above). Note that a drive may also allow enabling this feature by a jumper. Some SATA drives support the control of this feature by pin 11 of the SATA power connector. In these cases, this command may be unsupported or may have no effect.

If you really wish to enable -s or custom -S parameters, adding the async option to mount or something similar to

/dev/sdb1 /mnt/point ext3 errors=remount-ro,async 0 1

to /etc/fstab may help.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.