Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to install unrar package for my cpanel. as some people suggested that I need this package unrar-4.20-2.mga3.nonfree.x86_64.rpm . So when I run rpm -ivh unrar-4.20-2.mga3.nonfree.x86_64.rpm I get this error:

    [root /]# rpm -ivh unrar-4.20-2.mga3.nonfree.x86_64.rpm
warning: unrar-4.20-2.mga3.nonfree.x86_64.rpm: Header V3 RSA/SHA1 signature: NOKEY, key ID 80420f66
error: Failed dependencies:
    libc.so.6(GLIBC_2.14)(64bit) is needed by unrar-4.20-2.mga3.nonfree.x86_64
    libc.so.6(GLIBC_2.7)(64bit) is needed by unrar-4.20-2.mga3.nonfree.x86_64
    rpmlib(PayloadIsXz) <= 5.2-1 is needed by unrar-4.20-2.mga3.nonfree.x86_64
[root /]#

I saw posts suggesting to install EPEL and still the problem exists. I didn't see a relevant for installing the EPEL but still I tried and nothing worked.

Any suggestions will be much appreciated.

Note: I have Centos 5.7

share|improve this question
    
So you just downvote with no comment. or you just downvote when you have no answer? –  mamdouh alramadan Feb 25 '13 at 15:51
    
Oh, the reason is this: I answer and you delete my answer with no reason. I suggested that you can't install a Mageia rpm on a CentOS system because of incompatibilities. I suggest rpmforge, as it offers you a solution, namely a comatible unrar rpm and a repository. –  schaiba Feb 25 '13 at 15:56
    
Why are you trying to install a Mageia RPM on a CentOS system? –  Renan Feb 25 '13 at 16:05
1  
@mamdouhalramadan: You can't. Somebody else must have. I believe it takes more than one member to delete an answer, so the answer deleted must've ticked off more than one. –  rahmu Feb 25 '13 at 16:24
1  
@mamdouhalramadan: See my answer above: install rpmforge from here: wiki.centos.org/AdditionalResources/Repositories/… . Then 'yum update && yum install unrar' –  schaiba Feb 25 '13 at 16:25
show 4 more comments

1 Answer 1

up vote 1 down vote accepted

Install rpmforge from here: http://wiki.centos.org/AdditionalResources/Repositories/RPMForge#head-5aabf02717d5b6b12d47edbc5811404998926a1b . Then 'yum update && yum install unrar'

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.