Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've just upgraded my Debian Linux (Wheezy) to a 64 bit kernel, as well as user mode binaries, in an attempt to make use of the 4GB of memory in the system without PAE.

Exchanging the kernel and packages seems to have gone fine, but I'm not getting the expected result:

mymachine:~# dmesg | grep Memory
[    0.000000] Memory: 2007644k/2062784k available (3494k kernel code, 452k absent,
                       54688k reserved, 3042k data, 476k init)

mymachine:~# uname -m
x86_64

What could be causing this? I would like to expand the memory further, but if I can't even make use of the current 4GB, that is a bit useless :)

lshw output says shows the memory is properly installed:

 *-memory
      description: System Memory
      physical id: 29
      slot: System board or motherboard
      size: 4GiB
    *-bank:0
         description: DIMM DDR Synchronous 1333 MHz (0.8 ns)
         product: PartNum0
         vendor: Manufacturer0
         physical id: 0
         serial: SerNum0
         slot: DIMM A1
         size: 2GiB
         width: 64 bits
         clock: 1333MHz (0.8ns)
    *-bank:1
         description: DIMM DDR Synchronous 1333 MHz (0.8 ns)
         product: PartNum1
         vendor: Manufacturer1
         physical id: 1
         serial: SerNum1
         slot: DIMM B1
         size: 2GiB
         width: 64 bits
         clock: 1333MHz (0.8ns)

The Memory Remap Feature is enabled in my BIOS.

share|improve this question
1  
This seems very odd to me, since I've installed linux on various 64-bit 4 GB machines and there has never a problem with memory, using either either stock distro kernels or ones I built myself, going back at least to 2.6.x. Do you have a reasonably modern live CD handy? Try booting that -- if you still don't get all of it, something is definitely weird; post the first ten lines of /proc/cpuinfo. –  goldilocks Feb 24 '13 at 22:15
    
Can you see the 4G with the PAE kernel? –  Stéphane Chazelas Feb 24 '13 at 22:20
    
You don't happen to have some extra stuff in kernel commandline like mem or memmap, that would change it's behaviour, do you? –  peterph Feb 24 '13 at 22:37
1  
"I've just upgraded my Debian Linux (Wheezy) to a 64 bit kernel". This sentence concerns me. Did you try to upgrade from Squeezy or Wheezy 32 bits to 64 bits? Because if that was what you did... you better reinstall your system. Not only for this memory issue but for all 32 bits packages messing up your system and its stability. –  yzT Feb 25 '13 at 0:13
    
@yZT: The system upgrade went fine. It takes some time to fix some of the packages, but nothing serious. –  Thorarin Feb 27 '13 at 21:00

1 Answer 1

up vote 0 down vote accepted

Your motherboard apparently only supports 2GB or is buggy. See the bios e820 section of the kernel boot messages for exactly what memory your bios is telling the kernel it has.

share|improve this answer
    
Close enough... for some reason the motherboard doesn't seem to like this set of DIMMs. I tried different ones and they worked fine. Running with 8GB now. –  Thorarin Feb 27 '13 at 21:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.