Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I ran the following command in my terminal:

setxkbmap -layout us,ru -option "grp:lctrl_lshift_toggle,ctrl:nocaps"

but for some reason, the effect is the same if I specified "grp:ctrl_shift_toggle" - both Left-Shift+Left-Ctrl and Right-Shift+Right-Ctrl change my layout. How can I fix it?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

probably it is a remaining of a previous configuration If you want to ensure there are no previous options remaining, use -option (that is, an empty option instruction).

If I set:

setxkbmap -layout us,ru -option -option "grp:lctrl_lshift_toggle,ctrl:nocaps"

then I can switch with LShift-LCtrl and RCtrl does not.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.