Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I removed my LCD with Inverter, because it was broken. I'm using a Inspiron 4050 with a HDMI or VGA connected at TV, but the BIOS beeps(8times) continuos for ever and ever.

There is a way to control the beep volume or mute it through Ubuntu?

share|improve this question
2  
This should have nothing to do with Ubuntu, it is controlled by the BIOS. –  terdon Feb 23 '13 at 16:17

2 Answers 2

If Ubuntu is doing it, then the above answer is good. But "no monitor chipset" is a Dell BIOS beep code output.

8 Video memory read/write error. Missing or faulty video adapter.

Put in a cheap video card, maybe, the on-board chipset may be broken. You don't have to attach a monitor.

Failing that, physically detaching the PC speaker inside the case is a reasonable option.

share|improve this answer

The sound is most likely produced by the pcspkr kernel module. You can try unloading and/or blacklisting it:

There are several ways to disable usually noisy PC speaker in Ubuntu Linux (this is what beeps every time you wish to keep silent). The fastest one is just to unload its kernel module/driver:

sudo modprobe -r pcspkr

Add the the line “blacklist pcspkr” to /etc/modprobe.d/blacklist to turn off the speaker forever

source: http://www.linuxscrew.com/2009/03/17/the-fastest-way-to-disable-pc-speaker-in-ubuntu/

share|improve this answer
1  
Not if it is being produced by the bios. That module lets the kernel make beeps. –  psusi Feb 24 '13 at 1:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.