Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have added EPEL repo and here goes...

# yum install git-core
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons: mirror.team-cymru.org
 * base: yum.singlehop.com
 * epel: mirrors.servercentral.net
 * extras: mirror.steadfast.net
 * rpmforge: fr2.rpmfind.net
 * updates: pubmirrors.reflected.net
Excluding Packages in global exclude list
Finished
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package git.i386 0:1.7.3-1.el4.rf set to be updated
--> Processing Dependency: perl-Git = 1.7.3-1.el4.rf for package: git
--> Processing Dependency: libcrypto.so.4 for package: git
--> Processing Dependency: perl(DBI) for package: git
--> Processing Dependency: libssl.so.4 for package: git
--> Processing Dependency: perl(Git) for package: git
--> Running transaction check
---> Package git.i386 0:1.7.3-1.el4.rf set to be updated
--> Processing Dependency: perl-Git = 1.7.3-1.el4.rf for package: git
--> Processing Dependency: perl(DBI) for package: git
--> Processing Dependency: perl(Git) for package: git
---> Package openssl097a.i386 0:0.9.7a-9.el5_4.2 set to be updated
--> Finished Dependency Resolution
git-1.7.3-1.el4.rf.i386 from rpmforge has depsolving problems
  --> Missing Dependency: perl(DBI) is needed by package git-1.7.3-1.el4.rf.i386 (rpmforge)
git-1.7.3-1.el4.rf.i386 from rpmforge has depsolving problems
  --> Missing Dependency: perl(Git) is needed by package git-1.7.3-1.el4.rf.i386 (rpmforge)
git-1.7.3-1.el4.rf.i386 from rpmforge has depsolving problems
  --> Missing Dependency: perl-Git = 1.7.3-1.el4.rf is needed by package git-1.7.3-1.el4.rf.i386 (rpmforge)
Error: Missing Dependency: perl(DBI) is needed by package git-1.7.3-1.el4.rf.i386 (rpmforge)
Error: Missing Dependency: perl(Git) is needed by package git-1.7.3-1.el4.rf.i386 (rpmforge)
Error: Missing Dependency: perl-Git = 1.7.3-1.el4.rf is needed by package git-1.7.3-1.el4.rf.i386 (rpmforge)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

But...

# yum install perl-DBI
No package perl-DBI available.
Nothing to do

Any idea?

share|improve this question

migrated from stackoverflow.com Jan 27 '11 at 23:29

This question came from our site for professional and enthusiast programmers.

    
As perl-DBI is in the base repo you should use another base mirror. it seems yum.singlehop.com has no base packages. And this is not git or perl related. –  mugen kenichi Jan 27 '11 at 23:27

3 Answers 3

up vote 4 down vote accepted

So,

I was recently setting up a cpanel instance on this server, and I was pretty surprised as I have installed git without issue before on CentOS boxes before.

So cpanel has blocked all perl packages from being installed or updated because they don’t want updates to break or conflict with their packages. Thankfully yum provides a nice one time workaround for this kind of situation.

yum --disableexcludes=main install git

share|improve this answer
    
This works, and it looks like CPanel is still working just fine. Thanks! –  kpozin Nov 1 '11 at 2:43

Your basic problem here is that you're mixing the RPMforge and EPEL add-on repos. As you see, they're not always compatible. Pick one and use that.

share|improve this answer

Just remove the perl* from your /etc/yum.conf file..then rerun your yum install.

Make sure you remember to put it back in the conf file after you've installed git or some subsequent update may clobber something cpanel needs.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.