Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm taking an Operating Systems class online for college. It requires us to have a copy of Fedora 13, provided by our instructor, running on a virtual machine. On my machine, it boots to a message full of errors that ends like this:

enter image description here

I thought maybe it was just a problem with the instructor's virtual. I tried installing a fresh copy of Fedora 18, to see if I could get it to work for the class. When I do that, first this message flashes on the screen:

enter image description here

Then it boots up to show an image something like this, and stops there. The same thing happens even when I boot up in basic graphics mode from the Troubleshooting menu.

My teacher gave me another virtual, this one for VirtualBox. It boots up immediately to this message:

enter image description here

And for reference, my CPU is an AMD FX 4100. Fedora 18 on Virtual Box just goes to a blank black screen.

I have since tried Ubuntu, CentOS, Debian, OpenSUSE, Mint, Mageia, Windows 7 and Windows 8. Every single one of them worked without problems. Does anybody have any idea of what my problem could be? If it can be fixed, and how?

CPU:     AMD FX 4100
Host OS: Windows 7 Ultimate

Please let me know if any other information about my system is needed.

Update

I have enabled Virtualization in the BIOS. I then mucked around with the settings on this screen in VMware, trying every combination of item selections and check marks:

enter image description here

But none of them seemed to have any effect. However, I have made some progress with Virtual Box. My teacher's virtual still does not work. However, the error screen has changed to be identical to the one that I get with VMware, word for word, address for address. I've had better luck with Fedora 18 however, which has successfully installed in Virtual Box. So, that's some progress. However, the main issue is to get my teacher's virtuals working, because he wants to be sure all the students are working with the same setup.

share|improve this question
    
have you enable VT in Bios ? –  Rahul Patil Feb 20 '13 at 3:17
    
@RahulPatil: No, I have not. But then again, I don't know what that is. Any hints while I look into it? –  Benjamin Lindley Feb 20 '13 at 3:21
    
@RahulPatil: Virtualization Technology? Do you mean on my host's bios? Or on the guest? I didn't see any such option on the guest. I will now check the host. –  Benjamin Lindley Feb 20 '13 at 3:26
    
@RahulPatil: I found the option. It was not enabled before. It is enabled now. There is, however, no immediately apparent difference. –  Benjamin Lindley Feb 20 '13 at 3:45
    
Good to know.... –  Rahul Patil Feb 20 '13 at 5:00

2 Answers 2

up vote 2 down vote accepted

I would make sure that AMD-V is enabled in your physical systems BIOS.

BIOS

Something like this: ss of amd-v bios

VirtualBox (enable VT-x/AMD-V)

Something like this: ss of virtualbox amd-v

VirtualBox (enable PAE)

Something like this: ss of virtualbox pae

share|improve this answer
    
In the virtualbox screenshot, if you click on "processor", you can enable PAE from there. That is the problem with his Fedora 18. Hardware virtualization extensions are good, but not required. –  jordanm Feb 20 '13 at 4:10
    
Turns out that Enabling PAE/NX worked, but only after disabling VT-x/AMD-V. Strange. –  Benjamin Lindley Feb 22 '13 at 2:57

Just in case anybody else has same problem with F18.i686 on VirtualBox:

The problem in my case was that GRUB could not load the graphics. Using a chroot environment I did this:

echo "GRUB_TERMINAL=console" >> /etc/default/grub
grub2-mkconfig -o /boot/grub2/grub.cfg
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.