Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Having trouble tracking down a solution to the following problem. I am running Ubuntu 10.04.

~$ apt-get install valgrind
   Reading package lists... Done
   Reading state information... Done
   Some packages could not be installed. This may mean.... etc
   The following packages have unmet dependencies:
     valgrind: Depends: libc6-dbg but it is not going to be installed
   E: Broken packages
~$ apt-get install libc6-dbg
   lic6-dbg: Depends libc6 (= 2.11.1-0ubuntu7.8) but 2.11.1-0ubuntu7.10 is to be installed
   E: Broken packages

Any suggestions are appreciated...!

share|improve this question
@sputnick Checked gcc compatability; downloaded Valgrind separately and tried to manually install (after it was installed it output an error related to the above); searched the error; tried Synaptic; searched '2.11.1-0ubuntu7.x'... now, I am a beginner, so perhaps the solution was close, but I have been working on it for several days now to no avail. – d0rmLife Feb 20 '13 at 0:18
@d0rmLife Looks like you are mixing two different versions of Ubuntu. Don't do that. – jordanm Feb 20 '13 at 2:26
@jordanm Indeed, it is not a pure Ubuntu build. I am trying to become comfortable with Backtrack 5 r3 KDE 64-bit in preparation for an internship. Do you have any advice regarding my problem? Do you imagine any other bigger problems down the road? Is there a way around them? – d0rmLife Feb 20 '13 at 2:41
@d0rmLife have you tried with aptitude install valgrind ??? – Rahul Patil Feb 20 '13 at 2:46
@RahulPatil I just entered the command... says it will downgrade libc-bin, libc-dev-bin, libc6, libc6-dev, libc6-i386 and upstart. Score is 80. Is there a potential for adverse results from downgrading these packages? – d0rmLife Feb 20 '13 at 2:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.