Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

i have the following situation, i have a kvm host ubuntu 10.04 LTS 64-bit network host speed is perfectly run , as i am testing network speed using iperf , the speed between any network device and the kvm host is perfect running with 1GB/s but guest network speed is slow and the test result like 500 MB/s with any network device or with the host itself , although when i migrate this guest to another kvm guest based on rhel 5.3 the network speed works perfect . and when i copied the machine to another ubuntu 10.04 lts 64-bit kvm host , the network speed returns to the speed 500 MB/s

any one can help please

share|improve this question
    
Could you add more technical configuration details? How did you configure the network interface for the KVM (all possible details, bridge, driver, virtio, etc.)? In addition the respective's kvm and kernel versions of the Ubuntu hosts and guests as well as RHEL would be a plus! –  Huygens Feb 19 '13 at 9:43
    
@Huygens thanks for your fast actions , i configured the network interface in the first was a default bridge but the speed was 100MB/s maximum , and when i changed it to virtio the speed become 500MB/s maximum ,and host kernel version is 2.6.32-38-generic and guest kernel version is 2.6.18-128.el5(this guest is rhel6.3) but i also tried the ubuntu 10.04 lts as guest aslo i dont think it is related to kernel version i just read that it might be related to harddisk type might cause the problem , –  Moaz Refat Feb 19 '13 at 11:14
    
@Huygens and my hard disk is default drive , so i tried to change it to virtio hard drive also ,but i edited the xml file and changed it but the command virsh dumpxml vm > vm.xml still see the same old harddisk type ,and when i tried to remove the hard disk and try to import it and choose the type is virtio , the grub starts but after that a kernel panic error and can't mount /dev /sys /var , any suggestions please ? –  Moaz Refat Feb 19 '13 at 11:16
    
@Huygens after testing to change the hard drive device also to virtio , the network speed still the same. any another suggestions ? –  Moaz Refat Feb 19 '13 at 14:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.