Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

OS: Linux Mint 14 Tty: tty/6

I am trying to start X using startx from tty/6. I do not have a .xinitrc in my home directory. X gets loaded but it loads everything in chinese. I am not sure where the locale is set. Can someone explain why does it happen?

$ echo $LANGUAGE 
zh_CN:en
share|improve this question

1 Answer 1

up vote 2 down vote accepted

You are probably setting this locale somewhere in the ~/.bashrc or /etc/environment or /etc/profle or in a file in /etc/profile.d. Depending on the distribution, the way how the $LANGUAGE is set can differ.

Try this to find the file where your language is set:

grep zh_CN /etc/* /etc/profile.d/* /etc/bash/* ~/.*

if one of these files contains the setting, grep should show you

share|improve this answer
    
i found the LANG AND LANGUAGE set in ~/.pam_environment. Is it necessary to have both environment variables? Also where can I get valid list of values for these environment variables. I want the value for UK English. LANGUAGE=zh_CN:en LANG=zh_CN.UTF-8 –  rag Feb 20 '13 at 8:47
    
to be honest i don't know what ~/.pam_environment is. but i'm pretty convinced it's no problem if you change both settings of $LANGUAGE to en_US or en_UK –  mauro.stettler Feb 20 '13 at 10:12
    
i have removed $LANGUAGE and changed LANG to LANG=en_GB.UTF-8. this is also dependant on the locales package being installed. –  rag Feb 20 '13 at 23:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.