Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've searched everywhere and tried all the suggestions that I've seen, but I just can't get this to work now (it was working before). This is the first time I've ever installed a test server that I want to be accessible from outside my local network, so bare with me.

I have a test box in my home that is behind my router (192.168.1.1 gateway), server IP on network is 192.168.1.9 which I've set up statically in the router to receive the traffic. When I first set this up, I used a temporary hostname for the server that I was going to change, which after I have changed now is when I'm experiencing the issues. I have another colocated server, with it's own name servers, and in that server I quickly set up a CNAME entry under my main domain that pointed to my home IP address. Basically at that time this was working, and visiting the cname entry let me access the document root on my server at home.

I decided to change my hostname using a separate domain, and this is when everything went to shit. Here is what I did. In godaddy under my domain I setup 2 new hosts entries, ns1. mydomain.net, and ns2.mydomain.net that point to my home IP. I changed the nameservers for my domain to reflect these. I changed the hostname throughout the server, I setup BIND and added 2 zones to reflect my domain and IP address, and now I cannot get my domain name to resolve to my server.

Below are some responses that I get, if you need me to post any more output let me know as the DNS settings are what I'm not super familiar with.

I can access the web server document root fine using my wan IP address, or the dhcp address, but the hostname won't resolve, everything locally seems to work fine.

iptables

-A INPUT -p udp -m state --state NEW -m udp --dport 53 -j ACCEPT
-A INPUT -p tcp -m state --state NEW -m tcp --dport 53 -j ACCEPT

/etc/resolv.conf

domain mydomain.net
search mydomain.net
nameserver 192.168.1.1

other names resolve

nslookup serverfault.com
Server: 192.168.1.1
Address: 192.168.1.1#53

Non-authoritative answer:
Name:    serverfault.com
Address: 198.252.206.16

but not mine

nslookup mydomain.net
;; connection timed out; trying next origin
;; connection timed out; no servers could be reached

EDIT: After doing some dns lookups, I'm getting a loop detected message. "Loop detected! We were referred back to 'My home IP'"

Does this mean there is something wrong with my zone files?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.