Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Every networkmanager I've tried is "incompatible with this version" in gnome's settings panel. I can still connect from command line fine, but that's just kind of a pain.

Solutions I have tried:

  • pacman -Syu networkmanager installed everything fine, but didn't solve the problem.
  • pacman -S gnome-extra installed everything fine, but didn't solve the problem.
  • pacman -S gnome-network-manager: pacman says "package not found" (the package is outdated according to wiki)
  • pacman -S network-manager-applet installed everything fine, but didn't solve the problem.

The arch wiki says network-manager-applet should suffice for gnome, but the GUI won't support it, which is inconvenient. Any help is appreciated.

share|improve this question
    
The package name is networkmanager, so try pacman -S networkmanager –  don_crissti Feb 18 '13 at 23:06
    
What do you mean by saying that "installed everything fine, but didn't solve"? How does it not work after you did that? And I know that this question has been asked a long time ago, and it may have an solution already, but if it doesn't have an solution, you should update your whole system by doing pacman -Syu, which will update gnome too. Then it will probably work. –  Risto Salminen Dec 6 '13 at 9:27

2 Answers 2

Your problem is actually really easy to solve, although I can't blame you for not finding the solution - it isn't very clearly mentioned on the wiki.

The problem is that even if you've installed NetworkManager, the daemon does not run by default. To fix this:

sudo systemctl enable NetworkManager.service
sudo systemctl start NetworkManager.service
share|improve this answer

Use pacman -Ss to search for packages and pacman -Syu to install packages.

To learn about what the switches do in pacman you can use pacman -h. This will output all the main (capital letter) switches such as -S -V -D -Q -R -S -T -U. Each one of these also has switches that you can use, to find out what those are and how they work use pacman -Xh (replacing X with the main switch of your choice).

Also, try to post the exact errors that you're getting so we can get a better understanding as to what's going on. There are also a few of other network managing tools available such as wicd.

Take a look at this page on the Arch Linux Wiki. Should clear up any issue you're having.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.