Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I tried to install pulse audio, but after running ./configure I got a warning message:

===== WARNING WARNING WARNING WARNING WARNING WARNING WARNING =====
You do not have udev support enabled. It is strongly recommended
that you enable udev support if your platform supports it as it is
the primary method used to detect hardware audio devices (on Linux)
and is thus a critical part of PulseAudio on that platform.
===== WARNING WARNING WARNING WARNING WARNING WARNING WARNING =====


===== WARNING WARNING WARNING WARNING WARNING WARNING WARNING =====
You do not have speex support enabled. It is strongly recommended
that you enable speex support if your platform supports it as it is
the primary method used for audio resampling and is thus a critical
part of PulseAudio on that platform.
===== WARNING WARNING WARNING WARNING WARNING WARNING WARNING =====

I tried to find information about enabling these two services, but I couldn't find anything. How can I enable them?

share|improve this question
    
Why try to install it from source when it's available as a package? –  schaiba Feb 18 '13 at 10:22
    
@schaiba if i run pacmd and list-sinks, i was getting, name as auto_null and state as `SUSPENDED'. So i thought there is some problem with pulseaudio and hence i tried to install from source –  user20044033 Feb 18 '13 at 10:27
    
Solve that issue first and let the installed PA in place. You will avoid lots of problems. –  schaiba Feb 18 '13 at 10:29
    
@schaiba can you please give some ideas to solve that issue? i'm using linux for the first time. –  user20044033 Feb 18 '13 at 10:34
    
To be perfectly honest, I don't use PA and don't know much about it. But if your package manager offers you software, use it instead of compiling from source. –  schaiba Feb 18 '13 at 15:34
add comment

1 Answer 1

up vote 2 down vote accepted

These are not services, but compile options, use ./configure --enable-XXX to enable them (see ./configure --help first)

Also, to alter compile options for debian based distros, consider the debian way,

First use apt-get source XXX to fetch the source code, and use apt-get build-dep XXX to install dependencies,

Afterwards, change the debian/control file (which contains compile option),

Then at the top source folder, launch dpkg-buildpackage, when succeed, you'd see a few deb packages outside that folder, use dpkg -i XXX.deb to install it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.