Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I want to build a modified version of lighttpd. I follow this tutorial:

Downloading and building the H264 Streaming Module for Lighttpd (version 2)

This is what I've done so far:

apt get install lighttpd
apt get install automake autoconf libtool 
cd /var/tmp
wget http://h264.code-shop.com/download/lighttpd-1.4.18_mod_h264_streaming-2.2.9.tar.gz
tar -zxvf lighttpd-1.4.18_mod_h264_streaming-2.2.9.tar.gz
wget http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-1.4.28.tar.gz
tar ... 

After I copied all files and data to the directory and Makefile.am I entered:

./autogen.sh


./autogen.sh: running `libtoolize --copy --force'
libtoolize: putting auxiliary files in `.'.
libtoolize: copying file `./ltmain.sh'
libtoolize: putting macros in AC_CONFIG_MACRO_DIR, `m4'.
libtoolize: copying file `m4/libtool.m4'
libtoolize: copying file `m4/ltoptions.m4'
libtoolize: copying file `m4/ltsugar.m4'
libtoolize: copying file `m4/ltversion.m4'
libtoolize: copying file `m4/lt~obsolete.m4'
./autogen.sh: running `aclocal -I m4'
./autogen.sh: running `autoheader'
./autogen.sh: running `automake --add-missing --copy --foreign'
Makefile.am:8: lib_LTLIBRARIES must be set with `=' before using `+='

./configure --enable-maintainer-mode --prefix=${HOME}/test/lighttpd-1.4.28

The console returns:

    ...
        checking for pkg-config... no
        checking for libev support... ./configure: line 12184: syntax error near unexpected token `LIBEV,'
./configure: line 12184: `      PKG_CHECK_MODULES(LIBEV, libev, ,'
root@foo...

Some people solved this by installing "pkg-config". I installed this package but I still can't run the configuration.

EDIT: this is the source of the configure file at this line

LIBEV_CFLAGS=""
LIBEV_LIBS=""

    if test "$WITH_LIBEV" != "no"; then
            PKG_CHECK_MODULES(LIBEV, libev, ,
                    dnl no pkg-config for libev, searching manually:

                    if test "$WITH_LIBEV" != "yes"; then
                            LIBEV_CFLAGS="-I$WITH_LIBEV/include"
                            LIBEV_LIBS="-L$WITH_LIBEV/lib -lev"
  else

          AC_CHECK_HEADERS([ev.h],[
                                AC_CHECK_LIB([ev], [ev_loop], [
                                                LIBEV_CFLAGS=""
                                                LIBEV_LIBS="-lev"
                                        ],[
                                        AC_MSG_ERROR([libev not found])
                                        ]
                                )],[
                                        AC_MSG_ERROR([libev not found])
                                ]
                        )
                fi
        )
share|improve this question

1 Answer 1

up vote 2 down vote accepted

lighttpd-1.4.28 is not very current. You may be suffering from lighttpd bug #2300 Libev-4.0 isn't detected by lighttpd-1.x, this was fixed in 1.4.29 (backport from 2.0).

Otherwise, try:

  • double check your dependencies (specifically required versions of autoconf etc) as documented on the h264.code-shop.com instructions
  • make sure you can build lighttpd from source without the h264 module so that you can eliminate one problem at a time
share|improve this answer
    
I was able to build lighttpd-1.4.18 without any problems, so I assume you're right. I will download a newer version –  Goot Feb 17 '13 at 21:41
    
I just built 1.4.30. thank you very much dude. –  Goot Feb 17 '13 at 22:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.