Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've installed Steam on Debian 7.0 without any hassle, and I can run it by typing steam &.

I've set it as a desktop launcher in Xfce, but when I ran it, nothing happened.

Then I've check the "Run in terminal" option, and saw that it printed error messages about GLIBC_2.5 missing, which I had previously installed in order to get Steam to work.

I suspected that it probably needs my environment variables, and that Xfce isn't running it as "me" (why?).

After that, I've created a runsteam script and linked the desktop launcher to it. The script tried to execute my .bashrc to get the environment variables, but it had its permission denied.

I've set the variables in runsteam myself (copied from .bashrc), but the terminal window simply flashes and exits before I can see anything.

These are the relevant contents of my .bashrc:



How can I run Steam from my Xfce desktop?

share|improve this question
So what is your actual problem, I mean, what's the error you are getting? – NotFromBrooklyn Feb 16 '13 at 17:20
up vote 2 down vote accepted

This is an easy to fix bug, please see the 7th entry on my blog post about fixing common Steam on Debian Linux problems: http://www.yannbane.com/2013/02/how-to-steam-on-linux-debian-70.html.


  1. Right click on desktop
  2. Create launcher...
  3. Start writing "Steam" into the name box, and then select it from the suggestion.
  4. Create

Try to run it! I doesn't work, does it? Well, neither did mine, but I've figured out how to fix it:

sudo mousepad /usr/bin/steam, after the line that begins with a '#!' (shebang) add:


  1. Completely quit Steam.
  2. Try your new launcher.
share|improve this answer
Please include the important points of your solution in this post or you risk it being deleted as "not an answer." – Kevin Feb 16 '13 at 20:20
Thanks @Kevin, I have done it. – jcora Feb 17 '13 at 12:46

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.