Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

64-bit if that matters. My mouse sensitivity slider does nothing, but my acceleration slider works. I'd like acceleration off and sensitivity how I like it, but it refuses to work. I have tested the option on two computers, and both do not change the sensitivity. Any help?

share|improve this question
Tried a good ol' relogin? –  schaiba Feb 15 '13 at 17:40
What's your hardware? Is this a mouse or a touchpad? Can you adjust the sensitivity using another Desktop Environment? A live session? –  terdon Feb 16 '13 at 0:24
A relogin and reboots do not work. I've tried both a USB mouse and touchpad. Both don't work. Not a live session. I'll try a different desktop enviroment later. –  Elliot Yoon Feb 16 '13 at 0:57

2 Answers 2

From what I've been able to gather in a short time dealing with this issue is that in Linux/Mac OS X the mouse velocity is mapped 1:1. This means that when you move the mouse one point, the cursor moves one pixel. Depending on how many DPI the mouse have this could be slow/normal/fast for you. The actual 'speed' is controlled via acceleration. Unfortunately it seems that there's no simple solution to disable acceleration and yet increase velocity (having 1:n mapping) like in Windows.

The best solution I could find so far is provided by the user aib on this page:

In short, you set the acceleration profile to limited. This stops further acceleration once it's reached the value threshold which you set to 0. The acceleration value then becomes the velocity of your mouse cursor.

To permanently save this setting you need to edit a config file or create a script that will do that at startup.

share|improve this answer

You have to modify linux X Window Server settings. If you want to do it system wide (I'd highly recommend this because this way the settings will be applied to the login screen also), then you need to modify one of the xorg.conf files. For example, the following one: /etc/X11/xonrg.conf. If there is no such file, you can create one by yourself.

You need to do all the things as described here except that if you want to disable acceleration, the text to put into xorg.conf is the following:

Section "InputClass"
   Identifier      "Razer"                    # Whatever you want.
   MatchProduct    "Razer Razer DeathAdder"   # Product name from xinput list.
   Option          "AccelerationScheme"  "none"
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.