Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have tried running git instaweb start in two different repositories. In one it works fine, and indexes all the repositories in my home directory (even though run in a subdirectory). When run in another the web site simply says "404 - No projects found".

More information:

  • The top-level repository directories both have the same owner and permissions.
  • The "non-working" repository has an @ sign in the directory name.
share|improve this question
add comment

1 Answer

Found a likely cause while writing the question: Cloning the repository to a directory without the @ character in the name fixed it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.