Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have Linux Mint 14 Xfce (4.10) and have also installed LXDE desktop, so I can choose between these sessions if I want. Normally I would set one as default and at startup I am not asked for username&password and am logged in automatically as intended. (Under Settings/Login Window/Security - "Enable automatic login" is checked; and have also verified that /etc/lightdm/lightdm.conf contains the line autologin-user=cipricus.)

But even before installing LXDE I was asked for username and password after logout despite the fact that in Settings/Users and Groups I have the setting of not being asked for password on login.

enter image description here

In /etc/mdm/mdm.conf I see the line: AutomaticLoginEnable=true.

(Settings/Session and startup/General - 'Display session chooser' is unchecked. But this regards the other type of 'session': not the first type that involves selecting between users-passwords-desktops, but the one that involves selecting between sets of saved settings of the same user and desktop. More on this distinction/confusion here.)

I find it odd that if I restart the computer I can enter default session without password, but if I just log out the username&password are needed to log in. Opening computer and entering default session/DE: no username&password; selecting between sessions: username&password needed.

In the future I might decide to activate password at startup but I still don't want a password being asked in order to change or re-enter a session after the system has started.

Are there other settings to make?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Trying many possible combinations of settings I solved it but the conclusion is that there is something amiss with Xfce's session manager settings or GUI.

What I have verified is:

  • As stated in the question, when this problem happens, under Settings/Login Window/Security - "Enable automatic login" is checked, like so:

enter image description here

Enable timed login is not checked.

  • The odd thing is that in order to avoid typing username & password after logging out it is enough to check 'Enable timed login'. The login window appears but just 'Enter' is needed to start session in this case:

enter image description here

  • Even with 'Enable automatic login' unchecked, typing username & password after logging out is not necessary if 'Enable timed login' is checked.

enter image description here

That doesn't make too much sense to me, but it works.


Edit after restart: Because (related to a different problem - here) "Automatically save session on logout" (Menu/Settings/Session and Startup - General tab) was disabled, the solution above was not saved after startup. So, in case session automatic saving is disabled, make the 'good' settings as in the images above and in Menu/Settings/Session and Startup - Session tab: click "Save session" button.


In this way, after logout, username and password are not required to login in the default session, but are required to login into a different one. This may seem odd, considering the fact that in Settings/Session and Startup/General there is an option to 'Display chooser on login'. But checking that displays only DE-specific sessions (the ones saved within a certain DE, that is within the generic "session").

In fact it seems that passwords are asked for desktop environments, not for saved "sessions".

This double meaning of "session" is confusing.

There is no logic in this, this solution is just a limited workaround, there may be many other variables depending on other settings that I haven't touched yet.

For example, the login experience varies even depending on the style and theme of the login window... Some of the themes may display the username as a button (if Style "Themed with faced browser" is selected under Under Settings/Login Window/Local), but some may not; clicking enter as said above would enter the session directly; but clicking that username button makes necessary the password.

Hopefully this application (Xfce4-session) will be in better shape in a future update.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.