Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am compiling wxWidgets as a pre-step to compiling the newest version of pgAdmin3 since there isn't a deb version in the repository that supports version postgres 9.2. I am having troubles and eliminating possibilities.

The default package has a version of wxWidgets that works with pgAdmin3. I want to install the same options of this package.

When I type:

./configure --help

I get a whole host of options. How do I find out the options used to compile the default package version so I can match its functionality.

I have tried to use:

--enable-debug --enable-button --enable-ect.

but after 10 or so options I worry that I will miss something (and according to the output of the other compile I am) or I will add something that is conflicting.

Is there a list of options that the repository is using for wxWidgets.

Using Mint Nadia 14/Ubuntu 12.10.

share|improve this question
add comment

3 Answers

up vote 3 down vote accepted

There's a simple way,

First use apt-get source XXX to get the source code,

When extraction completes, enter the folder, i.e XXX-version, and check the debian/control file, normally you would see a DEB_CONFIGURE_EXTRA_FLAGS += line, that's where you should look at.

share|improve this answer
    
apt-get source did not work, could be because it is an outside package. Downloaded the deb from the repositories. The file existed, I checked for DEB_CONFIGURE_EXTRA_FLAGS wasn't there. Thanks. –  DarkSheep Feb 14 '13 at 5:13
    
@DarkSheep the deb file is the binary package, you need to get the source package –  Ulrich Dangel Feb 14 '13 at 15:12
add comment

I don't think you need any special options to build wxWidgets for pgAdmin. So just build it with default options.

share|improve this answer
add comment

I am 99% sure wxWidgets does not use special command line on Ubuntu for compile config. But make sure you check any missing development libraries dependency.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.