Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am just testing an rsnapshot installation on my laptop which should backup to a NAS mounted via nfs on my laptop.

On one test rsnapshot died with a cp -al problem (i.e. a problem with hard links) when moving daily.0 to daily.1, I think the problem was when it tried to copy the ../etc/alternatives/ part...

During debugging I tried to remove the directory daily.0 on the nfs manually on command line, however rm exited with the message killed. A similar problem occured with cp a few days ago though I cannot reproduce it (cp between two nfs subdirectories exited also with the message killed).

So is there any way to get more informative error messages from rm and cp to find out what's the actual problem is?

Edit After reading kyle-jones anwer I watched my RAM usage during several operations and confirmed that when I do something on my nfs mount on large directories, my memory fills up very fast up to 4GB (that's my physical memory on my laptop) and then the process is killed.

This happend for: cp, rm, du and even for ls.

As mount options for my nfs mount I used:

-o rw,hard,intr,tcp,actimeo=3 (and specified nfs via -t nfs).

share|improve this question
add comment

1 Answer

The "Killed" message isn't coming from rm or cp, rather it's coming from the shell telling you that the process was forcibly terminated with signal 9. The usual reason this happens is that the operating system is running low on memory and swap space and has no choice but to randomly kill processes to free up RAM.

share|improve this answer
    
Thanks, I just confirmed it seeing my RAM usage increased from 0,8 GB to 4 GB in a few seconds while trying to use rm on my nfs mount. When it reached the 4 GB it was instantly killed. –  student Feb 14 '13 at 8:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.